Italics removed when formating

Hi Guys,

I’m trying to copy paste (also tried import) a word doc to Scrivener but when I try to apply my format presets, I lose the italics on the text.
Could you please let me know how I can use the formatting below and still keep italics? I could always choose “Keep Italics” before, but that feature seems to be gone.

Indent: 0.2
Font: Adobe Garamond
Size: 12
Space 1.00x

Thank you so much!

Hi guys, I really really need help with this :frowning:

Not sure I have any big insights, but when you try to apply your format presets, how are you doing that? Are you:

  • Pasting the text and then selecting it and doing Formatting > Apply preset?
  • Pasting the text and then doing Document > Convert > Formatting to Default Text Style?
  • Pasting the text using Paste and Match Style (Ctrl+Shift+V)?

I’ve tried all three with a paragraph copied from Word, and only the last strips out italics (as it should). Of course, there may be other ways that I just don’t know about. I’m not familiar with one that has the option “Keep Italics.”

Pretty much all of the above :frowning:
None keep the italics option

Hmmm. At this point all I can say is, “How strange,” which is not exactly helpful. :frowning: You might need to contact Scrivener’s tech support directly.

When you say, “I could always choose ‘Keep Italics’ before,” in what context was that happening? And when? Scrivener for Windows hasn’t had an update for quite a while, so nothing should have changed recently.

Hi Clara –

Scriv developers anticipated this problem. You can make a new preset by selecting a block of text formatted as you like, and running Format > Formatting > New Preset from Selection. The menu command will prompt you for a name, and present a dropdown that defaults to “Save All Formatting”. If you set that instead to Save Paragraph Style and leave the other options checked, you’ll have a formatting preset that applies paragraph and font styles, but doesn’t mess with your italics!

Cheers – Jerome

As Jerome notes, it sounds like your preset has both paragraph and character formatting saved into it. Character formatting includes such details as whether or not text is italicised.

It may also be worthwhile to take a look at this knowledge base article, as I find the approach it describes there to be a better way of cleaning up pasted text than presets. But if you need something different for this than the default formatting you use while writing, a preset is best.

Thanks goodness–people who actually know something! :laughing:

Jerome, you’re a legend, thank you! :slight_smile:

Jerome, actually, is there a way I can apply the preset to the entire text documents in the project?

Jerome, actually, is there a way I can apply the preset to the entire text documents in the project?

Yes, by multi-selecting in the Binder. It’s described in AmberV’s link above. Establish the format you like via Tools > Options > Editor. Then select one or more binder docs as a test, and run Documents > Convert > Formatting to Default Text Style to be sure the docs display as you expect, since the formatting can’t be reversed. When you’re comfortable with the results, you can select every document in the binder and run the command again.

Rgds – Jerome

But in the screenshot attached, there’s no option that guarantees that italics will be kept. I’ve tried this option before, but it’s removing the italics. When I click—> set to default formatting, I get no option to keep italics :frowning: And then I lose them all.

You may lose italics with this tool if the target font you are using does not have italics included, or maybe also if the font’s italic face is addressed in a non-standard fashion. But if that is the case you will shouldn’t be able to set italic text at all in the editor, and there would be no way to get a preset working either if it changes text to that font.

There is no option for preserving italics with the Convert Formatting to Default Text Style tool because it is programmed to always preserve such forms of inline formatting if it can.

As for the screenshot—there wouldn’t be any mention of preserving italics there. That isn’t for converting text, that’s for establishing your default formatting when you create a new file in the binder. Now the tool that converts text uses those settings, but again the settings themselves are not “functional” in that sense, they are a reference point.

Thanks Jerome, you’re a lifesaver! Got my italics back. It was going to take me ages to go over them again.

A further thought on this. Scrivener very nicely breaks out font, font size, character attributes and paragraph styles in New Preset from Selection. So we have some control over which elements of prior formatting we want our new preset to overwrite.

It would be quite helpful though if we could separate the color attributes from other character attributes within the block. That way we could apply our favorite highlighting colors consistently by way of formatting presets (and accelerator keys) without clearing our bolds and italics.

Thanks for considering!

Rgds – Jerome