[JH] Breakpoint (Windows 7)

I don’t know if this is a Windows or Scrivener bug but… I installed v.3 on my netbook with Windows 7, where I write, and it closes when the backup folder window appears. I tried to be faster and click to change the path before… and:

The exception breakpoint
A breakpoint has been reached.
(0x80000003) occurred in the application at location 0xeaddf2c6.

Bang! :confused:

Thanks for the report. Are you getting this when using File > Back Up > Back Up To…, with the crash occurring when the “Back Up Project” dialog appears? Or is it not until you click the “Browse” button to open the file browser and select a location for saving the backup? In that case, do you get the same error opening the file browser through other commands, e.g. Save As?

Is Scrivener installed and running as an admin user or standard user?

Hi, Jennifer. It was installed and running as an admin user. The problem happens before the software is actually started. I took a screenshot:

Two seconds and it disappears. And I got the breakpoint message when I clicked the “Choose Backup Folder” button before this window closes.

Hi Jennifer,

I think I had the same problem when I first loaded 64-bit into CrossOver 17 … at least it crashed at exactly that point. I posted in the Linux thread attaching the backtrace, as I thought it might be a WINE problem:


I installed the 32-bit version which opened properly, then retried opening the 64-bit version which also worked. I have no idea about what was going on, but you can get my backtrace from that thread if it will help.



So, Jennifer. I can try to do what Mark said and make the software work with duct tape, not solving the problem, or wait for you to change the x64 Beta and test it here while it’s still clean. Tell me what you need/want to make the world a better place for all mankind. :wink: :wink:

:slight_smile: Thanks, both. Aleksei, could you please try launching Scrivener by right-clicking the “ScrivenerLog,bat” file in Scrivener’s installation folder and choosing “Run as administrator”? Once it’s run and crashed, refresh Windows Explorer and check to see if there is a “log” folder now in Scrivener’s installation folder, If so, please attach the .log file inside to your reply here (you may need to change the extension from .log to .txt). Also check to see if there is a “minidump” folder in Scrivener’s folder, and attach the crash file from this attempt at launching Scrivener if it exists.

Could you also try rebooting Windows in Safe Mode and see if you can launch successfully there without the crash occurring?

Hi, Jennifer.

That’s the sequence:

First ‘ScrivenerLog,bat’ (as administrator): ‘Scrivener-20180206-081628153.txt’, and no ‘minidump’.

In Safe Mode, the software was fine, did not crash.

Back in Normal Mode, still crashing.
So, second ‘ScrivenerLog,bat’ (as administrator) (since now I have chosen the backup folder): ‘Scrivener-20180206-083259834.txt’ and no ‘minidump’.

Hope it helps.
Scrivener-20180206-083259834.txt (9.57 KB)
Scrivener-20180206-081628153.txt (7.8 KB)

Thanks for trying that. What language is your system set to? The log file indicates that Scrivener’s crashing at the point that it checks for the text to speech voices. We’d made some adjustments earlier to how this is handled, trying to work around a crash that could occur when the TTS voices weren’t installed, but it may be what you’re seeing. You could try installing any missing text-to-speech voices for your system language, rebooting, and then launching Scrivener. This Microsoft article explains how to download and install voices for Windows.

Please also check that your video card drivers are up to date–we had a case where an odd crash occurred during startup when trying to load OpenGL video driver libraries, and updating the drivers solved the issue. Worth a try!

No worries.
The system is in English.
It’s a very light version of Windows 7 on this Netbook, just for writing. I’ll try installing TTS voices and playing with its video driver soon. I’ll let you know. But it’s too bad that I can’t use v.3 as v.1.

I am available for any other test. Thanks, Jennifer.