[JH] Bug: editing custom metadata (text) in column view moves section to bottom

Steps to recreate:

  1. Add a new custom metadata field (text)
  2. Turn filed on in column view + drag where you want it
  3. Edit field in column view by double clicking

Effect: edited section dissapears and ends up at the bottom of the list.
Workaround: after restarting Scrivener the error does not occur again.

P.s. the Windows version has been working great for me otherwise. Love it!

Possibly I’m missing a step, but I’m not seeing any shifting of the data or outliner rows when doing this. I wonder though if when you’re dragging the column to a new position, you might accidentally also be setting it to sort by that column, which then would cause the rows to shift when you edited the contents. Clicking into a column header will toggle it through Sort Ascending, Sort Descending, and No Sorting (restoring the original order). An arrow indicator appears in the column header when it is set to sort–do you see that in yours?
Outliner Column Sorting.png

Seem you are right (: I activate the column when I drag it over, so I guess I click once too many. Thanks. But something I discovered in the process is that adding a new metadata text field resets the column ordering in the list view? So if you have added a field and dragged it, adding a new metadata field makes them all appear as the rightmost column again.