[JH] Custom project templates don't work?

Hi!

I needed to create a new project template. I made a new empty project, made the necessary changes (added and assigned a folder of document templates and placed several templates there). Saved this project as a template.

When I tried to create a new project with this template - the start window don’t close, but a new project with the assigned name appeared in the folder.

When I tried to open this project, the program said “this is an old format”. OK, I agreed to convert it, but I still couldn’t open it (again “old format”).

I 've just created two new templates, created projects with both; as well as converting an old template and used it to create a new project. All have worked without issue.

I don’t have any suggestions, just reporting what I’ve done since RC5 was released.

I tried to create a project from an empty template and immediately saved it as a new template. It still doesn’t work.

Did someone else do it?

What version are you using?

RC 5
screen.png

That doesn’t look right. First it say what I’m supposing is Mar as the R is reversed and not May nor is it giving a day such as Sunday. :question:
Scrivener RC5 expire.png

Here’s a snap of translate.google.com:


So, yes, that’s RC5.

Just tried to reproduce this, but was not successful.

What I did: After login, and the project creation/selection screen, I chose a “Blank” template.
I added two folders under research, and saved the thing as a template in a custom category (I chose the name “Empties” as the category)
Closed Scrivener, and opened it again, and the template showed up in the list. No special folder for it.

The “special folder” for templates that’s set in “Projects” > “Special folders” is NOT the same as the folder where “Project templates” are stored. The templates that go in “Special folders” are Document templates, not templates for project creation.

Templates for project creation are saved (typically) in Scrivener’s Application Support folder, which is by default at C:\Users[your user name]\AppData\Local\LiteratureAndLatte\Scrivener\ProjectTemplates. You don’t even need to put something into that field; it’ll save them by default there.

Not sure that helps, though.

This is probably the peculiarity of Russian localization.

Please try creating a new project from this template. This is my problem

I understood.

If you assign special folders (templates) in a project, and then save this project as a template, you will not be able to make a new project from it. Even if you remove the settings for special folders later.

I think this is a bug (at least in Russian localization)

I don’t know if you are jokeing, guys, but that’s not reversed R. Я is a tottaly diferent letter which is pronunced like ya in mayan

Could you provide a zipped copy of a project that, when you select Save As Template…, produces this error? (I realize the error shows up later, when trying to create the new project from the saved template, but the issue seems to be with how the original project is saving, so the original project is what would be most helpful to see.) In a quick test I wasn’t able to reproduce this issue even in the Russian localization, so it would be helpful to work with a project that we know is failing in your case. Thanks!

Sure. An example of such a project in the attachment
Project.zip (23.3 KB)

I dl’ed the project sample, and was again unable to duplicate this bug. I set in project settings BOTH special folders, saved as a template, and produced several new projects with it. I tried this several times.

Shifted to Russian localization (I don’t read Russian, but by the places and the dialogs I could tell what was what), and did the same thing, exactly as the OP mentioned. Assign special folders, save as template, and create from template.

Projects were created successfully, and seem to work.

Russian localization seems incomplete. “Title and Synopsis” are in English in the Outliner, as are a number of others. “Label” and “Status,” however, are translated (at least, I see Cyrillic letters there).

Oh, I told you wrong. This error occurs if the project that the template is being created from is named in Russian letters. An example of this error is in the video (It’s 5Mb, I can’t attach it. Here is a link to onedrive: https://1drv.ms/v/s!Akkwdhbg6_eEhL06qh5qhvMb0T_TSg.)

Yes, the Russian localization is not fully translated. I can help (even though my English is not very good :smiley: )

All the localisations are incomplete. A long time, and probably a considerable amount of money, was spent on localisation when Mac v.3 was launched. The Windows betas were launched very soon after so that those of us Mac-users who use both platforms or collaborate across both platforms would be able to upgrade to version 3.

My guess—and it’s only a guess—is that completing localisation was put on hold until Windows v. 3 was fully launched, and the anomalies would be dealt with on both platforms at the same time.

My ½p! YMMV. :smiley:

Mark

Did you repeat it?

Yep. Using this latest info, about using Cyrillic characters for the project name, I was able to produce the error.

I noticed, on inspecting the project file created (it does create the project file), that the file length is 0 (ZERO) bytes.Obviously a problem.

So, the bug is confirmed. Other similarly-named files will save onto a Windows drive, so it’s probably not a Windows issue.