[JH] for 64 bit must deinstall 2.9.0.1, but doesn't cleanly work - recovery workaround

This one further small thing.

  • I think you should note to people to deinstall the previous beta before going on to the new release, if they are going to take the 64-bit version, otherwise there can be collisions or confusion, as think you’ll realize
  • deinstalling looked smooth after a delay, but then didn’t fully remove 2.9.0.1
  • this can be worked around in the mean time by then going to the old-fashioned Programs and Features, whose link you can find on the right column of the latest Win10 Settings>Apps and Features, or by searching for Control Panel on the Apps/Features searchbar.
  • You’ll then find the Scrivener beta on the list there.
  • You hould try to deinstall it again, and then will be told it wasn’t completely deinstalled, and asked if you want to fully remove it. Say yes, and then you’ll be ready to install the new release.

I was able to install 2.9.0.2 (64) into the same directory as first beta, without a problem. Win 10 latest.

Was there a specific message for the uninstall failure or any indication of what caused it? This sounds like an issue specific to that installation. Note that the uninstaller doesn’t remove any files except those created by the installer, so e.g. if you had downloaded dictionaries or had manually placed files within the Scrivener installation folder (which you shouldn’t do :wink:), they wouldn’t be removed when uninstalling and the installation directory would therefore still exist. That doesn’t cause an error, however; you’d just perhaps notice that the files were still there, so it sounds like that wasn’t the issue in your case.

Jennifer, there were no messages, just my notice that the Scrivener beta didn’t disappear from the normal Win10 modify/delete list of applications, after the uninstall completed.

I’ve just looked carefully through the horror that is Windows Events Viewer, and see no messages at all around the time of the uninstall-install. Curious, if MS only suggests how to find msi activities, which your installer isn’t. I tried other possibilities, of course, but didn’t succeed.

I don’t find a remnant folder either, though am pretty used to these from the past, There’s only my parallel 1.9.7.0 install in Program Files(x86). I could dig out a backup if you need to know where the original 2.9 beta was installed.

This brings me to what may minimize or avoid this problem, as has happened for @davidward apparently. If defaults were taken to install into an ordinary folder within Documents, it’s quite likely the overwrite install of the latest would just work.

I think to remember pretty clearly that I had not done this initially, instead putting Scrivener in a specially named folder in Program Files(x86). That’s likely the mode in which the later deinstall doesn’t quite take.

Ok, a little more information, which may help you judge about this – not probably so important after all, I think…

I realized I could search my backups via Retrospect without getting out the actual portable disk they’re on, and which is much nicer than fooling with Windows itself.

This found the original 2.9 installation – under LiteratureAndLatte, in the Appdata/Local folder (unaccessible unless you know how , for onlookers).

This had the expected amount of remnant folders, and not much else, but it does prove I think that I actually did take your defaults originally, after all.

Which means that probably most everyone did, so that either choice of most recent beta will install without issues – as mine would have if I hadn’t thought to avoid normal x86/x64 collisions.

I hadn’t added dictionaries either, to your question, just happily run the first beta for its period, as am starting to with the second.

Nice holidays, then…!
Clive

Jennifer, given the additional info, would you recommend uninstalling the 32-bit 2.9.0.1 before installing the 64-bit beta 2.9.0.2? Or allow the 64 bit to install on top (in the default folders, etc) and let the 32-bit remnants linger in the hard drive?

Thanks, Clive. It may just be the clash of having both 1.9.7 and the beta installed simultaneously, and not an issue with the Beta 1 uninstallation at all. At the moment, only one instance of Scrivener will appear in the Windows program list, so it was probably just still showing there because of 1.9.7 still being installed (despite whatever name it may have had on the surface). In any case, I think file-wise you’re fine, and the registry settings for 3.0 would all be updated with the new beta installation, so I expect things to be working all right.

Aurion, I would recommend uninstalling Beta 1 before installing Beta 2 (and I have updated the Beta 2 notes to explain this, thanks both). The default installation location on an administrator account is different for 32 vs. 64-bit apps, so in that case you’re not going to be overwriting the files at all. If you install to a custom location, or as a standard user, it makes less difference, though personally I’d still go for the clean installation. You can always save your preferences and reload them later via the Manage button menu in File > Options, and you’ll just need to rebuild the “Recent Projects” list by opening the projects once via the Open menu or double-clicking their project icons from File Explorer, etc.

Fair enough, though in fact both installs, 1.x and 2.x , did and do show on the main Win10 Apps modify/deinstall list – and that’s where I initially deinstalled from. This is very up-to-date Win10.

Glad to see you’re going with the deinstall-first as advice, in any case, as this is surely safest.

N.b. I run as non-admin, for the great boost in mal-things safety it gives, while installing etc. by temporarily allowing through an available admin login password. This in fact has resulted in funny looking Scrivener things I found with that backups search, such as (n extra?) license.txt in the admin login’s AppData. I haven’t dug into what that is exactly yet; no doubt I may have some amount of ‘extras’ from years of beta testing, even though cleaned at least once in past.

Not concerned about it; enjoy the season please!

(brave people who launch a release near holidays; I salute you (and your prior testing!))

C.

I’m having an issue where I installed the 2.9.0.2 and I’m still getting the message that the beta ended on 12/23.

I’m going to de-install 2.9/re-install and see if that clears it out.

Ah, I understand now what happened. That was totally my fault.

  1. I’ve still got the 1.9 version for books I’m working on right now and prepping to release.
  2. I initially installed 2.9.0.1 in the C:/Program Files (x86) directory because that was where it wanted to go.
  3. I created a link on my desktop to that 2.9.0.1 version.
  4. I installed 2.9.0.2 in the C:/Program Files directory (not the x86 version) because that was where it wanted to go.
  5. I tried to use the original link without re-pointing it to the new executable.

So that was totally my error.