[JH|LH2848] Compile problems

Aside from a really weird problem with compile I like many of the changes. Been using the beta for a while now.

I am starting to encounter a really strange problem. When I try to compile for Kindle e-book I get this error;

[b]"The Kindle book was created but with the following errors and warnings:

Warning(htmlprocessor):W28004: Absolute value specified for CSS property in content is not supported by Kindle readers. Please use % or refer Kindle Publishing Guidelines about usage of property: ‘line-height’ in file C:\Users<username>\AppData\Local\Temp\mdp<variable number>\OPS\css\stylesheet.css"[/b]

This was an upgrade from a Scrivener 2.x format. I have tried cut and paste to/from notepad to remove any odd characters, I have changed font and checked or unchecked nearly every box I can think of.

When the file finishes it gives me a readable (mostly) file BUT instead of apostrophe, I get something like this; “wasnâ € ™ t”

or something like;

â € œMy Lord has no horse or escort? â €  the Optio asked

where the quotes are funky.

I’ve also tried different fonts from calibry to segui. I can export it to a word.rtf file.

Any suggestions?

Thank you.

Thanks for the report, and the kind words! Compile is still being hooked up, but it’s great to know much of it’s working for you. :slight_smile:

The encoding problem for the eBook compile we’ve already logged for investigating, but the other error I haven’t see, nor am I generating it with just a quick sample file. It sounds like a line-height value in the CSS is assigned in points (or inches, millimeters, etc–a unit not relative to the font size or canvas), but I’m not aware of Scrivener writing that on either platform, so I’d like to see exactly where (and what) it is. Did this have any custom CSS?

If you use the same compile format on a new project with a bit of text inn a document to compile, do you get the same error? If so, it’d be great if you could send a copy of the format for testing, either attaching it here or sending it to win3beta@literatureandlatte.com with a reference to this forum post. If it’s only reproducing in the one project, a zipped copy of the project (which would include the compile settings) would be helpful. It might not be project specific exactly, but that at least would help us see it in context and figure out where the error is.