Keep elements together when compiling screenplay

I know this has been suggested in the past, but I couldn’t find a current status so I wanted to give it a nudge:

When compiling a screen play it is important that certain elements, most notably scene headings and proceeding action, and character name and proceeding dialog are kept together and not allowed to break in-between. (So as not to leave a character’s name orphaned at the bottom.)

Complicated behaviors such as “more” and “continued” aren’t required.

On the Mac version the character name is already kept with the following dialogue and the scene heading is kept with the following action (using Keep with Next). I don’t believe this is available in the Windows version just yet, but will be coming eventually - it will most likely come when the page view is added to the Windows version, as this involves Scrivener having a knowledge of where page breaks fall.

Thanks for the quick reply, Keith.

I’m a Mac user (2.4.5) and I’m not seeing this behavior. I must be missing something fairly obvious. Where is the “Keep with Next” option, I don’t see it in the script settings?

  • I found the advanced options in the Script Settings, and they are set to attempt to keep together.
  • I verified that the documents are in script mode
  • I verified that the proper script elements are applied.

I am still getting the incorrect breaks. (If I compile for Fountain and import into Highland, the breaks fall as intended.)

I can send the Scrivener file if it helps.

“Keep with Next” is under Format > Text, but you found where they are applied in script mode. Check that “Disable Keep with Next in page view” isn’t ticked in the “Editing” pane of the Preferences. Otherwise, before sending the file, please post or send a screenshot showing how it isn’t working in page mode.

Thanks,
Keith

I’ve attached a screenshot that shows the page view on the left and the PDF generated after compiling.

When you click into “BENNET” at the bottom of the page and then go to Format > Text, is “Keep with Next” ticked?

It was not, but why would it not be when the setting for that script element is?

How did you create these parts of the script? Did you write them in recent versions of Scrivener with this script format? Or did you import them from elsewhere? Or were they written in an earlier or different version of Scrivener?

They began as a Fountain document imported with the split into scenes option.

Aha, okay, after some testing, that is the problem. There’s a bug whereby the Fountain import ignores the Keep-with-Next setting of the script format. I’ve just fixed this for the next update. Normally I’d tell you to fix this by going to Documents > Conversions and re-convert your script format, but this won’t work as during testing I noticed that also ignores Keep-with-Next (the problem is that the OS X text system doesn’t actually support Keep-with-Next, so it’s a custom attribute in Scrivener). I’ve also fixed that for the next update. There should be a new beta in the Beta Testing forums in the next week or so, so look out for that, as that will include the fix.

All the best,
Keith

Thanks, Keith.