Keeps auto moving outside of quotes whenever I use '

It’s a common occurrence in my documents I have to paste something like <color=red>"" into the text, and then type something in between the quote marks. For some reason if I type any word inside it, it automatically puts my cursor outside of the quotation marks, which I don’t want done automatically.

What setting does this? This wasn’t an issue before but now I can’t even type inside quotation marks without this happening now. Yes, I tested this in editors other than Scrivener, it’s a Scrivener only issue.

Okay this was a really weird one…
Turns out the problem is present all across different programs, but for some reason wasn’t present in the ones I typed in.
Doing this in TextEdit had the same issue, which was fixed by going to my keyboard settings and specifying US English keyboard.
Still an issue in Scrivener, so I kept looking around until I changed the quote style to what’s shown in the screenshot which apparently fixed it?
One of the programs I tested it in and had no issues was Notes, which I’m guessing doesn’t have any auto format with quotation marks, but TextEdit and Screivener did, even after disabling smart quotes.

Issue seems fixed but it was super weird, and I’m not sure why it suddenly became an issue after having already typed in this manner for a while without issues.
Screenshot 2020-02-08 23.51.35.png