Keeps skipping the first chapter in the TOC no matter what

Using Windows 3.0

Oh, I am so frustrated with this. I honestly wish I never upgraded. 2.0 did it’s job well. This post is the result of about 10 days of just trying to figure out how to make a simple e-book after using Scrivener for 5 years. I’ve done things for a hour each day until it’s just been too frustrating to go on. Sorry, it’s just I’m at the point where I’m so angry it’s hard to lay out my thoughts.

I have this setup. Never used folders really. Originally I had a folder but I got rid of it thinking that might be it.

imgur. com/lwEk5fR

However compile gives me this.

imgur. com/X5Jh7ar

But the chapter is there. There’s just no reference in the TOC and there’s no break like the other 24 chapters. It’s toggled in the compile but I don’t know why it’s doing this.

imgur. com/Ohcd1c2

All I want is to show Chapter 1, have a link, and have a break between that and the previous ‘stuff’ in my front matter.

Thank you for your time.

Okay, I can’t have a link to images. There is an option to upload an image, but also a message saying I can’t embed images via the offered upload.

Okay. I’ll put spaces so I can show what they look like

I think in this case, it would help to see what the Contents list looks like in the compile overview area, on the right. That will show not only the “chapter 1” entry, but what type of item it is to the right. If it’s type is different from all the rest, you can also change it right there to match the others.

P.S. You should be able to put screenshots in your post now.

1 Like

Thank you. :slight_smile:

Would this be what you referenced?

Thanks, that’s informative. So it looks like the chapter is set up right, and thus something else is odd about it.

I would make a suggestion though, and that is that unless you’re really tied to your old legacy settings, using the “Ebook” format in the left sidebar is a much better place to start from than old stock settings. Reason being we put a lot of formatting and finesse into the design of that, which won’t exist otherwise. It may also solve the problem, because with that setup, “Chapter” layouts come with their own built-in section break, which it looks like your setup doesn’t do. There’s no harm in trying, if it doesn’t work out you can always switch back to the “Imported Scrivener v1 Settings” format without losing any settings.

  1. So click “Ebook” in the left column.
  2. Next click Assign Section Layouts to set up how the different parts of your book will be printed.
  3. We’ll just copy what you’ve got set up for the two types that print "as-is. Right-click on “Section Start” in the left column and select “As-Is” at the bottom. Do the same thing for the “Heading” type.
  4. Now for the “Section” type, which you are using for chapters, scroll through the various layouts in the right column and pick one you like. The simple “Chapter Heading” one may be what you want, as that will just print a numbered chapter heading. See how it says “Page Break” at the top though? That’s what you need, and what you seem to be missing in the current setup.
  5. Click OK, and give it a test compile.

Now going forward you may want to give your section types more meaningful names than “Section”. You could go into Project ▸ Project Settings..., and in the Section Types pane, double-click “Section” to rename it to “Chapter”. It’s mostly cosmetic, but it can be helpful to know what a thing is rather than using whatever upgraded names you got.

Thank you for that. I’ll give it a try in a bit. :slight_smile:

You explain very well and thank you for that. It’s MUCH more closer than before. I went with your suggestion to go with Ebook and renamed the types.

I picked a Chapter option and it showed none of the text (not a big deal), but I picked another and now the text showed. However how do I keep my formatting? If I have to put them in folders for each, I’ll do it. This may also be a case of me not picking/seeing the correct option.

I have this in Scrivener.

However it renders like this.

Basically I would like to keep the formatting of my words with the nice spacing between paragraphs (and font) especially with the game messages.

Thank you again. So to recap, the TOC is just fine. At this point, I would like an option to keep my formatting options for text so it matches what I see in the editor.

Oh, good call! I neglected to note that you were using single files for each chapter. It sounds like you found the right kind of Layout for that. You certainly do not need to rearrange your binder to fit any preconceived notions the software may have. It has none—and what you’re doing here is providing those notions. If you want a flat list of chapter files, that’s what you can do.

You should only consider using groups of items for a chapter if a chapter is going to be a long and complex enough text to merit having a nested outline of items in the binder. For example some of my chapters have upwards of 30 or 40 entries in the binder. It would be insane to have all of that at one level, and likewise it really would make no sense at all to have a bunch of folders that each have one single file in them.

Basically I would like to keep the formatting of my words with the nice spacing between paragraphs (and font) especially with the game messages.

Hmm, generally it is frowned upon to use both indent and spacing between paragraphs, since either one of the other is sufficient for a reader to tell when a paragraph starts.

As for the font though, that’s up to the book reader displaying it.

Thank you again. So to recap, the TOC is just fine. At this point, I would like an option to keep my formatting options for text so it matches what I see in the editor.

But if you really want:

  1. Open the compiler again, and in the middle preview column locate the Layout being used for chapters. Double-click on it to duplicate and edit it.
  2. This will open up a window that should be familiar from how the previous version looked in “All Options” mode. The Section Layouts section is how you set up the look and feel of the individual layouts themselves (and so it’s a bit like the Formatting section was in v1, but without all of the “Level 2+ stuff”).
  3. You should already be looking at the layout for your chapters. Along the bottom of the Formatting tab area, change the dropdown that reads “Text and notes use default…”, to “Text and notes use editor formatting”.
  4. You may also want to go into the Text Layout pane, and disable all of the “Remove first line indent” checkboxes, since it looks like you’ve already done the hard work yourself. Worth noting you can let the compiler handle all of that manual labour for you though, in the future!
  5. That’s probably all you need to change. Give it a useful name at the top of the window, and maybe save it to your global settings rather than the project, so it can be used in the future without having to do this again.

One other thing for future reference: you’ve probably seen how you can add the title of an item to the chapter heading in some of the layouts. If you had for example named “Chapter 1” as “Yaya” instead, then you wouldn’t have to put the title in the editor and try to wrangle getting things looking right between two entirely different areas of the software. You could just more simply use the Formatting tab in Section Layouts to design how the whole chapter break looks together. It’s probably too much work to do that now, so again, it’s one of those things to keep in mind for the next book.

1 Like

You are awesome. Let me just get that out of the way. :slight_smile: Again you have a very clear manner in how to present and let people follow information.

It looks… fine! I think I just need to tweak the other headings a bit (the front matter).

The front and back matter, but I’ll play with it. The bulk/main issue is fixed. I just wanted to give you a reply back. :slight_smile:

Thank you!

2 Likes

You’re welcome! Glad things are in a place where you can move forward again instead of fighting the new system.

Yep. Looks all good. The final step was just picking a template / layout I liked from the front and back matter since I didn’t have the need to have a header text. So it was more… let me try this. Compile. No.

Closer.

Kind of…

Oh! That’s it!

I’m done and ready to go. I appreciate your help very much. :slight_smile: