Keyboards and MMD


I don’t know if you have been following this thread: … .php?t=693, but apparently my Spanish ISO keyboard (natively like that) doesn’t allow me export correctly from Scrivener MMD to RTF or HTML. However, if I use my bluetooth Portuguese keyboard, it works perfectly. Is it possible for you to include Spanish ISO on the languages (keyboard) of MMD too?

If not that will mean that anyone that bought a MacBook Pro/MacBook with this kind of keyboard is doomed to have problems exporting MMD drafts. It will only work if you use a different keyboard – either using an external one (like I am) or setting a different language on the laptop keyboard. (For this one must know by heart the place of the correspondent keys.)

– MJ

PS. The regular Spanish doesn’t agree at all with the Spanish ISO keyboard. Too many different keys.

I am trying to remember who it is who dug up the alternate SmartyPants localisations. I think it might have been Janra? At any rate, Keith has only provided an interface to the underlying language system that MMD utilises.

I have already replied to the other thread. I do not believe this is a Scrivener problem. OS X handles all of this stuff - Scrivener does nothing with keyboards at all. MultiMarkdown has nothing to do with me - Scrivener just includes the option of using it for exporting. Fletcher may be able to answer your question.

To be honest, I am a little confused by your question as it is. I’m not sure what the keyboard has to do with exporting. Export handles text that has already been input, so it has nothing to do with the keyboard. Exporting uses UTF8, which should cope with most character sets, so unless Fletcher has any ideas about this, it may help if you could be more specific with your problem. What exactly is it that is not working for you? What isn’t exporting?



While preparing to write a more clearer exposition of the problem, I decided to make a few more tests on exporting MMD > HTML. Since I messed around with the Preferences (Typography) all seems to be working now. Apparently what AmberV told me before and changing the Preferences seem to have solved the problem… even with the Spanish ISO keyboard.

Needless to say I’m a bit embarrassed now. Something was going wrong, but it had nothing to do with Scrivener itself. Only with the preferences’ settings, that were wrong in the first place, and then with my own testing of it.

Sometimes being a scientist sucks… especially when we decide to bother people with our own ignorance. Thank you very much again AmberV; your earlier comment was in the right direction. Sorry, Keith, for asking something that wasn’t needed at all.

– MJ

PS. Of course now I’m annoyed by the fact that I don’t really know what resolved this. I only know that I changed something in the Preferences and that worked. That sucks too! There’s this saying on people learning from mistakes… but what was the original mistake I was doing? I think I’m going to test some more. :stuck_out_tongue:

No problem, valente - absolutely no need to apologise, that is what these forums are for. If you do find any more problems, let me know. And if you find out whether it was just the Typography preferences or whatever, you might want to post a note on the Tips & Tricks forum so that other users of Spanish ISO keyboards can benefit from your experience.
All the best,