Keywords no longer assigning to multiple docs - anyone else having this issue?

Typically I create a bunch of new documents, shift-click all of them, them drag relevant keyword onto the group to give them all the same keyword simultaneously. Today I noticed this no longer works - it’s only assigning the keyword to the top entry. Is anyone else experiencing this issue? Any suggestions on how to fix it?

Strange - I can’t reproduce this, as this is all working fine for me. What if you quit and restart Scrivener - do you still see the issue? Is this happening all of the time or are there any steps you need to take to get into the state where keywords only apply to the top document?

Yes - I can’t find any way of doing this. I’ve tried dropping the keyword (from the keywords pop up window) to multiple selected documents in the binder, in an outline editor window, and in a corkboard editor window. None of these seem to work. I’ve tried restarting Scrivener , and trying to repeat the process on a new small project. In my case it doesn’t even seem to attach the keyword to the first document, but as I have some already attached manually it I’m not 100% certain on that.

Attaching keywords one document at a time works as expected, but that doesn’t really help when a project has hundreds of documents.

Strange. I cannot think of a condition in which this would work, or any technical reason it wouldn’t, which makes this hard to diagnose since it is so far specific to your machine. Do you have a second computer you could test on?

Also, what if you create a second account on your computer (temporarily) and test on that? Does assigning keywords work fine there?

A couple of other things to try:

  1. In Scrivener’s Preferences, uses the “Manage…” button at the bottom to save your preferences to a file on disk. Then, click the “Defaults” button to reset your Preferences to the defaults, and, just to be sure, restart Scrivener. Does dragging keywords work then? If so, please attach the Preferences file you saved so that I can try with them. If not, you can use the “Manage…” button to reload your old Preferences from the file you saved.

  2. If (1) gave no success, close the project and, in the Finder, make a copy of it. Then, open the copy and try assigning keywords in that. If that still doesn’t work (it shouldn’t be any different), close the copy of the project again and then, in the Finder:

a) Ctrl-click on the copy of the project and select “Show Package” contents.

b) Drill down into the /Settings folder inside the .scriv package.

c) Delete the “ui.plist” and “ui-common.xml” files".

d) Try opening the copy of the project again and see if that helps.

Note that (2) is almost unlikely to have any effect if this is happening for all of your projects, though.

Finally, if none of the above yields any results, would it be possible to make a small video showing your process of dragging the keywords, in case there are any small clues I can pick up from seeing everything in action?

Thanks and all the best,

Sorry, just did a search for ‘keywords’ and didn’t realise this was the Mac forum… Anyway, I have found the solution for the Windows beta - dragging the keyword (as per the manual /videos) definitely does not seem to work but right clicking on the selected keyword gives an option to add or remove the keyword from the selected items.