Keywords with numbers and hyphen disappear

I tried to create keywords like “8-18 yrs” (without quotations marks) by clicking the “+” button and typing. Whenever I finished typing the whole phrase, it disappeared from the keywords list. I can see it in the keywords HUD, though the “yrs” was cut off. When I tried to create the keyword in the HUD directly, the first part “8-18” remained while the “yrs” was gone. Could you please fix it? Thanks!

I’m using Os X 10.6.6 and Scrivener 2.0.4(7817).

Happens on the 2.0.45 beta as well; seems to be a problem of the numbers following the - sign [I say, stating the obvious]. You can get the same result just typing “-90 word” (the “word” will be cut off), typing “word-90 blah” (“blah” will disappear) and with multiple hyphens (“90-11-2 word” will cut off “word”). I get this even when a space is left between the hyphen and the number. It doesn’t seem to happen with with non-numeric characters following the hyphen.

In the Inspector panel I’ve gotten both the whole keyword disappearing (appearing only in the HUD, but truncated) and with the last words (anything after the last number following the hyphen) cutting off after I hit enter. Console occasionally throws this error:

Scrivener[2261] Bad _contents: -1

It’s not every time, though.

OS 10.6.5


It seems like anything except numbers following a hyphen will cause the keyword to disappear from the Inspector. For example, “-90” and “-900” are okay, while "-90 " and “-90a” are not.

I created a keyword “-90” in the inspector and it showed up in the HUD. Then, I double-clicked the “-90” and added a letter “a” to the end. The “-90a” disappeared from the inspector and a “-91” appeared in the HUD instead. Therefore, rather than having “-90” and “-90a” in the HUD, what I got was “-90” and “-91”

No error messages in the

It sounds as though the auto-numbering code is getting in the way. I’ve added it to the list for investigation for 2.0.5.