Kindle icon not showing after compiling

Another day another problem with Compiling.

I’ve conducted numerous Compile test in fine tuning my novel for Kindle. Each time after compiling, I would get the spiffy Kindle icon showing a hardcover book in blue with an “a” on it. Now when I compile, I’m getting just the white page icon with the folded corner, though the contents seem to be fine.

I want to send out advanced copies to readers for review, so it would be nice to get back the Kindle icon. Could one of my Compile settings be causing this? If not, any other suggestions?

(If AmerbV should read this, please also see my follow-up question to your answer regards my last query on ToC–THANK YOU!)

The OS is responsible for displaying a file icon. For standard file types it comes with a number of icons right out of the box, like for PDF, RTF, HTML and so on. For every unknown file type it uses the generic white icon you described.

This changes with the installation of a program that opens certain file types. The program brings its own file type icons which replace the old ones, wether the generic white ones or already existing specific ones. By doing so these file types are not only internally but also visibly linked to that program.

As far as I remember the blue book icon for e-book file types like .mobi, .azw, and. azw3 are not part of the standard file type set of OS X. The blue book is only displayed after the installation of dedicated e-book apps like Calibre or Kindle for Mac. Which one I can’t tell as I have been using them both for quite a long while.

If I’m right that leaves two options for your case:

  1. Scrivener does not save the .mobi file with a .mobi file ending (the option to set the file ending to invisible has no influence on this). It does so on my Mac and the fact you can open the file without any problems indicates that Scrivener’s compile process is working fine.

  2. In the present state of your OS X .mobi is not linked to a dedicated e-book app anymore. So maybe you have recently de-installed one of them? Sometimes the related “Open With” settings somehow get confused. You could try to reset them by a command line or a maintenance app like Tinker Tool (free, not to be confused with Tinker Tool System which is for pay).

But anyway, if option 2 is true you can unhesitatingly send the file out and the reader will see a blue icon if he has an e-book app on his computer—and he probably will even if the computer is not his preferred e-book reading device. You even can do this to verify if option 2 is right.

Suavito–Thanks very much for this explanation.

I don’t use Calibre but am using Kindle Reader for Mac. I did trashed it and reinstalled again. And the problem happened after that (but not immediately if I remember right). Might reinstalling it a second time possible help, do you think?

The Compiling is saved as a .mobi ending okay.

I’ll send a copy to someone and see if they get the proper icon. If they do, I don’t I’ll mess around with Terminal or the SW you mentioned.

At first I’d recommend you to do a right-click on one .mobi file. Then choose “information” (or whatever it is called in an English user face).

In the information window look for the “open with” part. If it doesn’t say Kindle for Mac set it to Kindle for Mac. And then set it to “open all”.

Maybe that will already fix your icon problem.

If not, maybe de-installing and re-installing Kindle for Mac helps. Use the Terminal/command line only if you are experienced with it. Tinker Tool was just a suggestion, there are most certainly other free tools that can do the same.

Suavito–Your last suggestion worked! Changing the setting to work with Kindle reader. I downloaded Kindle Previewer and this must have changed that setting. When I booted up today the blue book icon was there smiling at me.
Thanks again for taking the trouble to respond.

Glad I could help.

I’m having the same problem after updating the Kindle app on my laptop three days ago – the icon no longer shows the blue A even though none of my Compile settings were changed.

I tried the suggestion (going into the mobi file, selecting Kindle) and that opens the doc in the Kindle app but doesn’t change the icon from the white doc image to the blue one, and the library icon image for it in my Kindle app for iPhone and iPad is blank (no longer shows the cover). I tried reinstalling the Kindle app, but that didn’t seem to work either.

Any other suggestions for what I might try? Thank you in advance!