Kindle output extra spacing between paragraphs

Amazon sent me a quality issue about my ebook. They said there is unnecessary extra spacing between paragraphs.

I checked my source file and it all checks out. I only have one blank line. On the kindle it looks like the height of two blank lines.

How can I correct this? I’m running the current release from the Mac App Store.

Thanks

Tim

My guess is that Amazon don’t like you having physical whitespace between paragraphs. Just delete the blank line - really, spacing between paragraphs should be handled by line spacing rather than by physical line breaks. If it’s only in one place and used as a scene break, though, that is rather odd that they would bother about that. It’s difficult to know without more information, though. Please post the text of Amazon’s email, and screenshots of:

  1. How the offending part of the text appears in Scrivener with invisibles turned on (Format > Options > Show Invisibles).

  2. How the text looks on the Kindle (e.g. in Kindle Previewer).

All the best,
Keith

Here is the info you asked for. A screen shot of scrivener. I tired adjusting the “Set Line Spacing” height down from 1.0 to 0.5m but it did not affect the Kindle output file.

Hi,

Okay, I see the problem, and it’s as I thought. You can see that you have placed blank lines between the paragraphs in your text:

So changing line spacing settings won’t have any effect, because you have actually inserted blank lines between paragraphs. You should avoid doing this (and obviously Amazon don’t like it). If you want spacing between paragraphs, you should use the “Paragraph spacing before” setting of the line spacing options to set a 12 point gap or whatever rather than typing two return characters between paragraphs.

You will need to go through the text and remove all double return characters. Here’s how I suggest you do that to make sure you don’t mess anything up whilst keeping things relatively quick:

  1. Load up the whole draft in scrivenings mode (or you could do it chapter by chapter).

  2. Hit Cmd-F to bring up the Find panel.

  3. In the “find” text field, hold down Option and hit return twice. You won’t see anything in the field, but this will insert two return characters.

  4. In the “replace” field, hold down Option and hit return once.

  5. Hit “Next” to find a double line break.

  6. Hit “Replace” - the double line break should be replaced by a single one.

If that all looks fine, hit “Next” and carry on using “Replace & Find”.

All the best,
Keith

Thanks Keith.

Two questions.

  1. I only see one CR symbol. Although its large, how does that equal two?

  2. “Paragraph spacing before”, is that in the output settings when compiling?

Thanks so much for your help, its greatly appreciated!

-Tim

There’s one beeline symbol at the end of the line before; one on a line of its own. Thus, two. The point is that you shouldn’t have blank lines between paragraphs; you should only add spacing between paragraphs using line space formatting, not by hitting return twice when you get to the end of a paragraph and want to start a new one.

Paragraph spacing before is indeed an option in Complile, by selecting the line spacing control in the format bar of the “Formatting” control and selecting “Other” (or spacing from the Format menu). You can set it in the main editor, too, but most likely you are overriding formatting during Compile anyway.

All the best,
Keith

Thanks a bunch Keith.

I’ll make the corrections and get it re-submitted.

Keith,

I’m getting really close to the output I need. But I have one questions.

How do I get the compile to ignore adding “end of paragraph spacing” to portions of the text body. Like an address for example should read.

Dr. Jones
123 Street
Anywhere, USA 12345

Instead it reads this way after the compile.

Dr. Jones

123 Street

Anywhere, USA 12345

Thanks
-Tim

There are a couple of ways. If that is in a document on its own that doesn’t require a title or anything inserted at the top (e.g. a title page or front sheet), you could tick “Compile As-Is” for that document. If it’s just a chunk of text within a document, select the text you want to have different line spacing, ensure it has the right line spacing in the editor, and use Format > Formatting > Preserve Formatting. This will place a blue box around the text, which just indicates that this has been “zoned off” from Compile’s regular settings. Compile will not convert the formatting of this text then. (Although if you want, you can tell Compile only to preserve certain aspect of text with “preserved formatting”, via the “Options…” panel in the Formatting pane of Compile.)

Hope that helps.

All the best,
Keith

Keith,

I was able to highlight the text following your directions. However, the output did not change. I tried with with the different options shown below. What am I missing?

On a second note, after I get all of these settings figured out. Is there a way to save this as a compile template?

Thanks again for all your help. You’re a lifesaver!

Tim



Strange - I just tested exactly the same settings and it worked fine for me. You haven’t got “Compile As-Is” ticked for the document, have you?

You can indeed save the settings as compile settings for future use - choose “Manage Compile Presets” from the bottom of the “Format As” list, which will bring up a panel. You can click on “+” in that panel to add the current settings to your saved settings.

All the best,
Keith

I tried it again tonight after work. No go. I don’t have the Compile-As-Is for that document checked. I’m actually trying to save the formatting in two areas of the book and neither are taking.

I’ve tried it by checking the AS-IS and that didn’t affect it either. Maybe its a function of the iPad Kindle app.

I can publish it the way it is, I was just looking for a little more polish. Thanks for the help. We got my main issue worked out.

How does it look in Kindle Previewer? That should show you how it will look across several devices.

I’m happy to take a quick look at the project if you want. Just zip it up and send it to mac.support AT literatureandlatte.com and mark it for my attention.

All the best,
Keith

Another good call Keith.

It looks correct in the kindle mac app. So it must be an iPad thing.

Thanks again. I learned a lot through this trouble resolution.

Thanks again!

-Tim