L&L Website appears broken on iOS

My apologies. I know this isn’t the website’s forum, but there’s really no place to post about website problems. Please, moderator, move this to a more appropriate forum if possible.

I usually use the forum on iOS. In the past two days, the forum menus have stopped working on my iOS devices. I use Safari on an iPhone 8+, and an iPad 6th Gen, both running iOS 12.4. The menus in the upper right corner of the website (see screenshot below) are no longer responding to taps. I’ve tried using an alternate browser, iCab Mobile, but the menus aren’t responding in that browser either. I’ve tested on my Mac, and there the website menus are working fine.

To be specific, it’s these menus that I can’t invoke on iOS:

Seems there are also L&L site issues on Windows & Mac too. Possibly related thread: [url]https://forum.literatureandlatte.com/t/cant-download-manual-website-issue/46703/1]

I saw this this morning on iOS, but I’m happily going through the site on my Mac without problems. Maybe they’ve fixed it in the meantime.


Should be good now, hopefully. :laughing:

Yes, working! :smiley:

This is still evident for me using a Macbook Air 13" at each display resolution, macOS 10.14.6. The following things get no response:

Forum — Dropdowns for Logout at forum name and Notification Bell (advances to user control panel for notifications instead). Dropdowns/Links at top of page for Products, Community and large Ellipsis. Can upload an attachment but can’t place it inline.

L&L website — Dropdowns/Links at top of page for Products and Community.

The above findings were for the latest Safari. Just tried Firefox 68.0.1 and everything’s working.

EDIT: Cleared Safari cookies and caches again. Either that fixed things or you did, or it’s an intermittent issue. All set for now. Thanks.

Just a note that the original problem highlighted by silverdragon persisted for me on iOS until today, when I followed scshrugged’s cue and used the Clear History and Website Data for Safari in Settings on my iPhone. All menu buttons are now working again.