Label and Status both grayed out

I only have this problem with one Scrivener file. I have experimented with creating new labels and statuses (stati?) but that does nothing.

Where are they greyed out, and what are you looking at in the editor?

in corkboard mode. in outline mode, I don’t get the greying out but I still can’t get the stamp to appear.

I don’t understand this question, sorry.

There is no way to turn on stamps in Outliner, anyway. That is just a corkboard feature—a way of showing status on an index card. In Outliner, there are no special graphical ways of showing data, you simply add or remove columns to it.

I need to rephrase my question though, when I asked “Where are they greyed out”, I meant in what specific piece of the software are they greyed out? In the Inspector sidebar, in a contexual menu? I’m having trouble thinking of a scenario in which they would ever be greyed out at all. Right-clicking on the Draft, Research or Trash folders themselves, I suppose.

When I asked what you are looking at in the editor, I meant the answer you gave to the first question: a corkboard. The editor is the big section in the middle, where what you click on in the binder on the far left is shown in various ways, depending on what it is you clicked on.

So just let me know precisely what sequence of actions (all mouse clicks and menu commands) are you are taking to get to the point where you are seeing greyed out meta-data options.

Suggestion. Go back into the normal writing view. In the Binder (the blue column on the left), click on a document (not a folder, but one of the single scene documents in the folders), and choose a label for it in the Inspector (over on the right), and also choose a status for it.

Now go to View/Corkboard Options, and tick Show Pins and Show Stamps.

Go back to the Corkboard view, and I think you’ll now see the label (colour) and status (stamp) that you put on your document.

with a little fiddling, this worked. I have a bug where, whatever I put first in my list of possible stamps, won’t appear. so I moved my “default” stamp (“Finish!”) to lower in the hierarchy.

however, I still can only stamp cards in Outliner. I still can’t do that in Corkboard. the stamps appear in Corkboard but I have to add the stamps in Outliner, and, as I said, I still have a bug there.

I don’t use a mouse, just a mousepad, so I don’t right-click. (perhaps you can right click using a mousepad but I lack the knowledge and/or manual dexterity.)

last night I did look through the Scrivener manual for help with understanding things like the Inspector sidebar and contextual menu.

best way I can put it: when I click on the wheel/cog-shaped icon to the right of the folder icon to the left, a window appears. I can get to the Label and the Status part okay. I can go to the Edit part at the bottom okay. but I find most of that part grayed out so that I can only stamp or label an index card by going to Outliner.

and as I said in my previous post, I still have a small bug. I hope that what I just wrote makes sense?

On a Mac, it has always been possible to access a contextual menu by holding down the Ctrl key on your keyboard and clicking normally. This used to be the only way you could do so, until they started to support third-party mice with secondary buttons.

Additionally, in the trackpad system preferences pane, you can set it up to access the “right click” menu when you click with two fingers instead of one. I even prefer to set it to tap instead of click so it’s even easier.

Got it. Yes, that is the other way you can “right click” in many Mac programs. Well that should definitely be working. I would be curious to hear if actually right-clicking on a card is messed up as well.

And you definitely do have something selected on the corkboard when you click on the gear button? The way you describe the menu is what you will see if nothing is selected. Large portions of the menu will be greyed out because these actions are meaningless without a selection.

Now that you have researched how to use the Inspector, one way to verify what you have selected is in fact the Inspector. The index card at the top of that is where you’ll find that info. Below that are the menus for label and status. When I’m just changing one card at a time, I usually use the Inspector. I tend to have it open anyway, and I find that easier than using the menus.

But the menus are useful when you want to change the label for more than one card.

This is working fine for me, so I need more information to see the behaviour appear on my computer. For instance, maybe you have 30 status types and what you are describing is merely the fact that the menu is too tall for the screen and you need to scroll up. With my paltry seven stamps, I would never see such a condition. Could you post a screenshot of your Project/Meta-Data Settings window, on the Status tab?