Label and status text in the Outliner is now black in dark mode after Catalina update


I just updated to Catalina (10.15.3) and the label text and status text in the outliner has turned black when using the dark theme.


Try applying a different theme, and switching to light mode and back. If that doesn’t work then try this: … y-settings

Thanks for the advice and the link.

The problem still occurs in all dark themes and the default Mac dark theme.

Resetting the display settings didn’t work either.

All the best,

Has anybody else found that they have this problem running Scrivener with a dark theme?

It would be great to find out if this is a bug that can be fixed in an update, or whether it’s something specific to my system that I need to try and hunt down.

Many thanks,

Is anybody able to reproduce this problem?

I am still unsure as to whether it is a bug in Scrivener or unique to my system setup, but it’s been going on for a few months now and it would be nice to get it fixed.

Many thanks for any help.

As no one else has replied with a solution, this post is just to say that running Catalina 10.15.4 (Apple Logo > System Preferences > General > Appearance > either Dark or Auto) and Scrivener 3.1.5, I cannot replicate the issue you are seeing, So long as the cursor is in the outliner, the text looks fine in the two default dark themes supplied by L&L: Solarized Dark and A Midsummer Night. Or have I misunderstood?

Solarized Dark.jpg
A Midsummer Night.jpg

Thanks so much for your reply. That was exactly what I was hoping to find out.

Whichever combination of system theme and Scrivener theme I use, the dropdowns for Label and Status are still illegible:

Screenshot 2020-05-14 at 18.06.32.png

Screenshot 2020-05-14 at 18.07.39.png

I can’t find anything in the preferences that might affect these items.


Is that the same in all projects?

Have you tried reinstalling the software? Maybe something is messed up with the UI in the version you have installed. The text your demonstrating in screenshots should adapt automatically to the background colour—even in light mode if you set the background dark enough it should switch over to white.

If Ioa is following this thread, I will bow out, with a sense of certainty that Ioa will get this resolved for you.

One thing I did wonder about was resetting the project’s display settings, if it is a problem with one project: … y-settings

But take Ioa’s advice above all.

Hope you finally find a solution to the issue.

Hi, thanks for the replies. :slight_smile:

Yes, all projects have the same problem.

I have just tried reinstalling Scrivener but the problem persists. It’s the same with new projects too:

Screenshot 2020-05-14 at 20.04.04.png


Thanks for your help. :slight_smile:

I did try resetting the project’s display settings too,

Ah. Hope Ioa replies with another idea. Do you have a sample project you could zip up and share on the forum: just with dummy text?

Would be interesting to see if the issue persists in the project and displays incorrectly on another Mac.

Thanks for taking a look. :slight_smile:

Here’s a test project where the problem occurs. (37 KB)

If I flick through different background colours in the preferences, all the other text changes accordingly from dark to light, but not the Status and Labels text.

Hey, Ian.

Thanks for the sample file. It displays correctly on my Mac in dark mode, so definitely not anything getting universally applied at a project level.

Very odd that only “Status” and “Label” are problematic on your Mac.

Some things I would try, after making sure my projects are all backed up.

  1. Your website uses dark colours. If you are someone who likes dark colours for most interfaces, is it possible you have a display setting on your Mac that might be overriding part of Scrivener? I have no idea what that setting might be, but you might be aware of a personal tweak you have made.

  2. Create and switch to another user account. If the issue persists, it is a system-wide issue. If it doesn’t, it is user-account specific.

  3. Boot into safe mode to see if the problem persists:

  4. Reset Scrivener’s preferences

  • Save any current preferences (Scrivener > Preferences > General > Manage > Save Preferences to File [and store safely]) as a file that you can revert to

  • Load “Defaults” from the same menu

  • See if “Defaults” clears the issue

  1. If a standard reinstall didn’t work, I’d try:
  • Deactivate Scrivener licence from the Scrivener menu (make sure you know your licence details before you do this)

  • Quit Scrivener

  • Use AppCleaner to wipe Scrivener out comprehensively (but not project files / backups / saved preference files / etc):

  • Shut the Mac down (not soft reboot)

  • Boot the Mac

  • Download a fresh install of Scrivener and reinstall:

  • Test to see if working

  1. Long shot: reset NVRAM or PRAM:

  2. Another long shot: reset the SMC:

  3. Run the full maintenance mode of Onyx to clear out caches etc:

  4. Hope Ioa or another user comes up with a fix

Good luck.

Thanks for that - that’s a great list of things to try out - I’ll work my way through them. :slight_smile:

It’s interesting to see that the problem doesn’t occur on your system, so that narrows things down a lot. I do run my Mac in dark mode, but I have tried turning it off, to no avail.

Thanks again for your help - I’ll let you know how I get on. :slight_smile:

Just to add that I don’t think it likely to have occurred with a system setting that I might have tweaked, as the problem began the moment I updated to Catalina.

Hopefully might be narrowing things down a little:

I booted up in safe mode and the selected Scrivener window had light text for the Labels and Status.

When deselected, the text went dark again.

When fullscreen the text remained light.

When I reverted to a normal boot, the problem returns.

Any ideas what might be causing this behaviour? :confused:

Just to say that I am running Catalina 10.15.4 on a 2013 MacBook Air. I usually use Windows machines, but bought the Mac purely to be able to run Scrivener 3, so there isn’t really anything else on the machine,

I created a new user as you suggested and everything displays correctly. :slight_smile:

Do you have any ideas how I could fix my current user settings?

I tried resetting the Scrivener preferences, but no luck.