Lagging in Full-Screen Mode after Mojave

Hello!

So, I just updated to Mojave, which might not have been the wisest move just yet. :confused: Scrivener is lagging, just a bit in the normal view, and a lot in the full-screen mode. I changed the autosave from every 2 seconds to every 15, rebooted my computer and Scrivener, but so far, it’s still lagging.

Anyone else have this issue? Any suggestions on how to fix it? :frowning:

I don’t have any issues here, and I’m using a fairly old Mac (2012), so I’d probably spot in generalised performance issues with it. I’d make an effort to simplify the editing view as much as possible. Remove all peripheral elements like the ruler, line numbering and so forth. Turn off any dynamic features like invisible characters, spelling and grammar check, and finally anything else that might complicate rendering by adding extra processing time to everything you do, such as page view and editor zoom levels. The idea then is that if performance improves, to turn your desired features back on one by one, and check for lag as you do so.

Sometimes the easiest way to do all of the above is to create a new blank project, turn off the few things you need to, and then copy and paste some material from your main project into it, to test with. That way you don’t disturb your project settings.

If none of that helps with the source material you’re working with, then see if something in there is the problem. Do you have hundreds of footnotes in the editor? Lots of graphics (or a few massive ones)? Etc. Does this happen with 5,000 words of pretty plain text?

As far as projects go, this one’s pretty sparse. A few documents of plotting notes, but I’m a pantser, so the bulk of the content is the actual novel, which is only about 15k right now. I have like, one picture, but it’s not huge. And it didn’t make a difference before Mojave. :frowning:

I’m just frustrated because nothing else changed on my laptop, and all my other apps are running fine. I don’t use the ruler or anything in full-screen mode. It’s just a picture of flowers in the background, then my document. Nothing I alter in Scrivener seems to make a difference…

I just created a new project that’s totally empty, and it’s still lagging when I type in full-screen mode. :frowning:

Just to be sure: Does the lagging only occur in Scrivener? Or do you see it elsewhere?

I have a 2018 iMac with fusion drive and upgraded to Mojave. For a few days (maybe 2-4?) after the upgrade, I got serious lagging on typing, but it was not consistent, but random, and happened in all applications. I suspect it was the result of one of the issues with the upgrade that are discussed here:

eclecticlight.co/2018/10/12/moj … -molasses/

After than initial period, I have had no problems with lagging in Mojave.

Which version of Scrivener do you have? – Katherine

It’s just in Scrivener that I’ve seen. I moved my novel to Word for the time being, and have had no problems there, or with my emails, Chrome, excel, Slack, etc. :frowning:

I’m using Scrivener V 3.0.3…

When you say there is a picture in the background in “full-screen mode”, do you mean the Composition Mode backdrop, set in Project Settings, or some place else? Have you tried resetting preferences yet?

I understand 10.14 is the only thing that has changed, but that can represent quite a lot, under the hood. That’s a bit like saying that the only thing that changed about the plant is the house it is in! :slight_smile: For programs like Scrivener that are built directly on Mac technology, it can fluctuate when a major upgrade comes out. It’s an ongoing process tracking down the thousands of different ways Scrivener gets used.

We’ll have a 10.14 compatibility update out soon, so if you would prefer to just wait and see, you can do that. Otherwise here are some of the steps I take when running into issues after a major OS upgrade.

⠂─────── ⟢⟡⟣ ─────── ⠂

  • First I get the software in question back to a factory default state. Who’s to say if a setting I use is at fault or not, but leaving all of those intact is hundreds of variables that cloud the issue. If nobody else is having lagging issues in 10.14, it stands to reason that the factory default settings should in theory be fine. We can’t say that with any certainty for any other single checkbox being changed. Reseting the preference file is the best way to do this.
  • For lag and performance issues, I start by launching Activity Monitor and Console, switching the former to CPU tracking and the latter to Errors and Faults mode. Are any process consuming more resources than seems reasonable? Are these spikes in usage accompanied by a lot of errors? Are there hundreds of errors rolling by every second?

For example I have a tool that makes my trackpad, mouse and keyboard much more configurable. After installing 10.14 everything was awful. Half of my clicks wouldn’t register, everything was slow. I checked these two tools and found this utility was repeated crashing and restarting in an infinite loop of malfunction, and every time it crashed it was seizing up input—that’s why half the time when I clicked nothing happened, because I clicked while it was crashing. I shut that down and removed it from the auto-run-on-login list and suddenly I felt like I had a new Mac. I updated the utility, reinstalled it, and all was fine.

  • Basic maintenance. An OS update disturbs millions of files on your disk. Run Onyx or Maintenance, let disk checking run, clear all caches and databases, and reboot. Note everything will be a little slower than usual after doing this for a while, as it rebuilds indexes and caches.
  • If that doesn’t work, I create a new Mac account and run my tests there. Is the problematic software doing fine? If so I go back to my main account and strip out all of the background software that automatically loads on login. No Dropbox, nothing. I switch them back on one by one, and before doing so I check each utility for updates. I give it about a half hour before going on to test the next.
  • Of course if even logging out and back in with no software running but Scrivener and Finder, and it’s still slow, then I start considering an account swap. It’s something I find necessary every other OS update—a clean start for your user folder. If you just click “upgrade” year after year, a lot of junk builds up—I’d say a good 90% of the performance and stability issues I’ve personally experienced on my Mac are down to some manner of grit in the gears, so to speak. Moving your important document files over to the new account, and only gradually copying over settings if you’re comfortable with that, is a pretty easy way to get a fresh start.

Most of these programs, it is worth noting, are not true Mac software. Some have whole programming environments ported over from other operating systems, 100% bespoke interfaces like Chrome, or not even really software in the traditional sense, but fancy web pages running in a stripped down web viewer like Slack. I don’t mean this in a “no true scotsman” kind of way to be clear, I just mean: these kinds of things cannot be used as a reference point for whether or not Scrivener should work flawlessly.

A bit off-topic, but—

Gems like this are why I lurk on these forums! I had never considered an account swap as a less-intense cleanup step before the nuclear option (backup, reformat, clean install)—and, boy, does my Mac need this! I haven’t had a new account since I did my first OSX installation, (mumble) years ago, and that was… 2 macs ago? Three? I just keep using the automatic transfer from my old Mac, & the usual upgrade paths. I will definitely do this when I upgrade to Mojave. Thanks!

I’m a Windows user most of the time, but I switched to a Macbook two years ago to take advantage of the iOS version of Scrivener, which is just prettier overall… So I think I’m just frustrated that after such a big change, Scrivener now isn’t running on the one OS I wanted it to. :confused:

I appreciate the tech stuff, but it’s all a little in-depth for me. Word is working just fine, so I’ll just keep checking for software updates on this website and try again then. Thanks anyway. :slight_smile:

Hi, guys. I landed on this post today because my Scrivener was suddenly lagging only on my two (weirdly enough), NaNoWriMo WIP projects. I thought at first it could be because I had webpages tagged in my Research folder, but even after duplicating the project and deleting them, Scrivener was still lagging in full screen composition mode.

Then I tried changing (of all things) the background image because I am not facing the same problem with my other projects that had more than 50,000 words and webpages in the Research folder.

Weirdly enough, this worked! I picked an entirely different background and this one worked for the two projects that were lagging before.

Though this doesn’t explain much about what went wrong technically, this weirdly helped me. Now my Scrivener performs as normal on composition mode.

Good luck to anyone else who has the same problem and I hope this somehow helps you too.

If you’re doing NaNoWriMo, then all the best!! :smiley:

I used to be a Windows user too, but I switched in 2010 and never looked back! My current Mac is two years old as well, and I have recently updated to Mojave. I too have this sudden experience of lagging when typing in full screen mode. Changing the background image as I had somehow helped it go back to normal.

I hope you get to experience Scrivener as it is meant to. I’ve written on MS Word as well, and it doesn’t compare to Scrivener especially when you hit the 10k, 20k, words mark. Actually, I am not sure at which point MS Word on Mac will start lagging as I have only done my thousands-word count writing on Scrivener, but I have friends who has experienced it after their text gets heavy on word count.

Are you doing NaNoWriMo?

Likely if you optimised the image you are using a bit further, it would work better. I don’t see any generalised issues with the Backdrop image setting as it relates to typing performance. But sure, if I put a really huge image into settings, I do see a speed loss (which is to be expected, it’s a matter of how fast your computer is at that point).

Newbie here, you surely don’t mean the desktop background, do you? :open_mouth:

I’ve noticed the same thing happening with the wheel of death popping up at an annoying rate and scrolling acting patchy. This happens mostly in full screen mode. I’m working on a 9.000 word document with around 25 images and lots of footnotes.

It is doubtful the desktop background would be a culprit. Scrivener itself has several different settings for adding backgrounds and textures to the Composition Mode writing environment. In Project ▸ Project Settings…, under “Background Image”, you can assign a Composition Mode backdrop, which takes the place of a solid colour around the text editing area. You can also add a texture file to both the background and the text editing background itself.

Now Full Screen mode is another matter—I don’t know why that would act differently from not being in Full Screen, as this is pretty much just maximising the window, putting it on its own “Space” in Mission Control, and hiding all Mac interface elements. The interior of the window itself is fundamentally identical to a regular window.

I’ve been lurking on this thread (I haven’t taken the Mojave plunge yet, but I’m keeping up with potential issues.)

@Fornwalt42, would you please clarify for me? Mac Scrivener has two different full-screen modes: Composition Mode and “ordinary” full-screen mode, which is available to any Mac app. To which is this thread referring?

No, not the desktop background. It was the Background Image on Composition mode that I’m referring to. Like Amber V said, it could be due to the quality of the photo I used. As for speed, I’m using a 2016 MBP TB on a 16GB RAM. I think it’ll perform better on 32GB. Probably that’s why too. I worked on the same projects (with the very same background image that was giving me problems on the project) on a 2015 MBA and had no problems.

I see. Well, I haven’t changed said background, so I’m using a solid colour. Writing on a mid 2015 MBP with 16 GB RAM as well. But that should hardly cause such lagging, or?

We have at least one report that lag introduced by upgrading to 10.14 has been mitigated or fixed in the public beta. It might be worth checking that out—even if only to see that once it is officially launched, this will no longer be an issue for you.

Hmm that’s not the case here… Mine is running 10.14 and I can make it lag by clicking through 3-7 texts or folders and then the wheel of death will pop up. After that, scrolling might also cause the wheel to show.
The wild clicking is a sure way to cause the lag but I do notice it when working normally without trying to over do it. Like when I’m typing, then wait and then insert a line break and continue writing.