Lagging when I type? [BUG LOGGED]

If I type really slow, scrivener doesn’t seem to have problems keeping up. But as soon as I speed up at all, it freezes after typing TWO letters and then lags for FOREVER.

It is incredibly frustrating! My computer is not slow, was top of the line a year and a half ago. quadcore ram, plenty of hard drive space, etc. It’s NOT my computer that is slow. (and the only other thing i have running is iTunes)

Oh and my typing is NOT extraordinarily fast. (at the HIGHEST maybe 90wpm, average of more like 60)

Is there anything i can do to fix this? I was really looking forward to this programme, but it looks like i might just be using Microsoft word after all…

Oh, and this does not seem to have an effect in note cards or anything like that, just the main typing area.

Thanks for this release!

My typing lags, sometimes, but the lag never lasts. When I turn on annotation, or footnotes it does lag.

omg. i thought this was only me. soooo frustrating though. ;__;

I have had issues with lag sometimes, after working for a while, and restarting Scrivener seems to clear it up. This leads me to believe some condition in the program is breaking, but I have as of yet been unable to discover what that is. Do you happen to remember what it is you were doing prior to the lag appearing?

For me it can get to be quite bad—as in the text doesn’t show up for 10 to 15 seconds. As soon as I restart Scriv though, it goes back to be snappy.

Hmmmmm, I THINK I may have imported an image and then went back to creating sub-folders for my outlining purposes. And then it just started messing up. I thought it may have actually been my PC but all it was still lagging after I closed limewire.

EDIT: and i restarted, and it’s back to being snappy. xD

I also had issues with it lagging as I typed but as AmberV says, closing the program and reopening it makes it speedy again.

I had split a large document into sections and then sat down to write some new text in one of the sections. As reported, the first two characters would appear and then I’d get a lag of several seconds before the rest appeared.

I’m running Windows Vista.

That’s exactly what I get, Mary. One or two characters pop up and then nothing for seconds on end.

How about hardware? One place I’ve never seen it happen on is on my higher performance computer. I’ve seen it happen frequently on my little netbook though. How much memory do you have in your computer, do you know the chip speeds?

I’m experiencing the lag problem on my desktop computer and can give you my hardware and software information:

Software: Windows 7 Professional, 64 bit
Processor AMD 1800 Mhz, 4 core processor
Physical RAM 5 GB

I experienced lag not only during typing. I imported an existing work into Scrivener for Windows, and started splitting it into scenes. Each time I clicked the “Split” command there was a long lag before the focus returned and I could click on the newly created scene.

Let me know if I can give you any other information

It’s a Lenovo T61 that’s about a year and a half old.

Processor: Core 2 Duo 2 GHz - L7500 @1.60GHz
Memory: 2 GB Ram
System type: 32-bit Operating system
Software: Windows Vista with service pack 2.

Also, I notice that we are both in Portland, OR.

There has always been a peculiar density of Portland denizens on this forum for some reason. :slight_smile: Must have something to do with our city-wide book lust culture.

Anyway, looks like my speculation on hardware is a dead-end as both of these systems are quite a bit more deadly than my poor little Asus.

How large were the files you were splitting, Vanessa? I’m getting some disk access lag on large operations. For example, loading 20k words worth of documents in Corkboard—there is some delay. I don’t think this is related to the typing lag bug though, as it is fairly consistent. It seems to just be a matter of parsing speed—going through all of the sub-files in the project folders at rapid speed—whereas the typing lag problem is something that happens even in a small little file of 10 words once triggered.

Hi AmberV

The original RTF I imported was 338 K - not sure why the RTF was so big, as the manuscript was about 33,000 words. The files got smaller as I progressed through splitting the scenes in Scrivenes and speed did improve.

I tried just now splitting a 3300 word chapter into 2 files, and it went quite quickly, so it may not be a serious problem. Importing doesn’t happen that often. The lag in typing, however, is a real problem.

One thing that might be helpful for splitting in a future version is to allow users to put a special string Scrivener would recognize between scenes in an RTF file. yWriter does that and it works very nicely, automatically splitting the imported document into scenes.

Wow, you’re going through these bug reports like an energizer bunny!


Yes, I have been on scrivener just now for about an hour and have gotten a lot of work done (yay) but the type is SO slow. It does not matter how slow I type, I can never actually see the typing. I will type a sentence or a block of text and after a long wait, BAM, there it is.

I’d find myself actually sitting there for 1-2 minutes waiting for it to catch up. I ended up just opening Microsoft Word, typing into that, and THEN copy/pasting into Scrivener. Hope it gets fixed.

I am just completely overwhelmed by the number of reports. It’s fantastic that so many people are interested, but Wow!

The roadmap for Windows is like this: catch up with Scrivener for Mac 1.x, and release for sale. Then, catch up with Scrivener 2.0. The feature you recommend, “Import and Split” is a 2.0 feature that already exists on the Mac, but because it is a 2.0 feature, it probably won’t be in the Windows release for some time. It is however, on the docket. :slight_smile: And yes, it is quite nice.

KillerMermaid: That’s awful; shouldn’t be that slow. Restarting doesn’t fix it up for you at all?

I agree. I’m getting this problem too under the novel template.
It’s actually right now frozen, has been for maybe 5 minutes now, because of me typing too fast.
Ah well. I understand why you stress backing up!

Thanks for releasing this for windows, though! I’ve been eyeing Scrivener for years.

Edit: my computer is fairly fast, and now that I rebooted it, it seems to be working better, but gets slower at random intervals.

I’m having the lagging problem as well - to the point that after a moment the next few words will eventually appear, but the rest of the sentences I was typing appear to be lost. After restarting, it doesn’t lag, but I’m not sure if it will start hanging again as I go on.

Didn’t import a document, did set up a number of notecards.

Lenovo SL500, running Vista

Thanks for bringing this to windows - I hate to say, but I’ve been semi-seriously switching to mac, just because I wanted this so much!


Asus 1000HE; 1.66Ghz Atom, 1 GB RAM

The program seems to, well, slow down and come to a halt after leaving it for a while.

How it looks like on my screen is that it is now a split pane. Things I did before I noticed the lag:

  1. Made new Research folders
  2. Copy-pasted some text from
  3. Tried typing. Super lag.

Gonna try to find the problem.

If anyone can find a 100% reproducible case of this, you will be a hero. :slight_smile:

Hey: Is anyone suffering slowdown once they paste in any form of long extracts of ext?

Edit: Nope, don’t think that’s the problem.

I’m having severe problems with lagging as well.

Sometimes when I type, everything is fine. Sometimes, it types one letter, goes blank, refuses to let me click anywhere and stores up to about 1 sentence in memory which is then displayed some time later (1-2 minutes), with anything typed beyond that lost in the ether.

I am using a very stripped down system with only Chrome running in the background.

OS: Windows Vista SP2

It’s a shame because otherwise, this is everything I had been hoping, but the lag makes it unusable.

[Edit] Although not an ideal fix, the lag seems to go away when I restart the software (no need to restart the machine).

That’s all fantastic feedback. I never have a lag problem as I type too slow so I never picked this up previously. So, thank you.

I will log this as a bug and see what we can do to optimise performance.