Language incorrection

Hi Again!
Not sure if this is a bug or not:
I have uploaded the French spellcheck and set the language. It works.
But when I try to set some substitutions, eg
lf for langue française and
af for Académie Française
I’m not getting them. Instead I get
lf -> Lof
af -> fa
also, when I use my “reminder finder” of XXX, I get EX
I’m assuming I’m getting another preset series of substitutions, but don’t know how to set it to what I need.
Also, oddly, I have deleted the 1st -> 1° etc substitutions more than once but they keep reapearing
and, testing, 1st, 2nd … 4th I get 1sot, 2NCD, 3Re & 4thé, telling me it’s correcting à la French.
Any help appreciated!

Try deselecting “Correct spelling errors as you type” there in the Corrections options.