LaTeX Problem - Missing \begin{document}

Hello,
I am new to Scrivener and exploring functionality. I am working on a PhD proposal in Economics and would like to work in Scrivener, rather than Word. However, my work is mathematical and I would like to export to LaTeX.

When I export a TEX file at present, the file does not have the necessary front matter. For example, there is no \begin{document} command in the TEX file. This means it will not compile. Fine, I can imagine putting the front matter in by hand, but I am not keen to do that. And what I have read online suggests this is an abnormal problem (example: orthostat.wordpress.com/2013/02/ … up-update/). The link here provides a lot of info on how to set the meta data and latex options, which I tried in my trial version of Scrivener. But the TEX files that I have compiled with MMD still do not have the necessary front matter (\begin{document} ), even after putting this into the Latex options in Scrivener as described in the link above.

Please do reply if you have encountered this situation before (no \begin{document} in TEX files from MMD in Scrivener 1.5.7 for Windows) or can provide useful insights. This experience is leading me to think that I should start by using Scrivener to organize my writing, produce equations in Word, and combine in final copy in Word - which is workable but not ideal. Thank you in advance for your comments! Goodbye.

MMD has two modes of operation:

  1. Snippet Mode: this produces the text as merely formatted, without any document containers, using the native format’s codes for doing so. So an HTML file would have paragraph, strong, em and so on. A LaTeX document would have what you describe. This makes it easy to drop text into an existing template or system.
  2. Document mode: if you need the whole document, then you would simply add document relevant meta-data to the MMD file. Giving something a title is good enough to do this.

If you compile your work as plain MultiMarkdown instead of going straight to some end format, do you see a properly formatted meta-data block at the top of the file, with document-class meta-data described there? What method are you using to attach meta-data to the compiled output, in Scrivener?