Layout manager and inspector's panels disposition. Bug?

Hi.
I don’t know if this is wanted or not (searched the manual, but didn’t find anything related), but it is a bit annoying that the layouts don’t store the inspector’s panels’ sizes.
You can clearly see the difference here, in the snapshots’ tab :


Only 4 rows of snapshot titles should here have been displayed as the top panel.

Every time Scrivener is restarted, the size of the top and bottom panels goes back to 50/50.

. . . . . . . . . . . . . .
There is also another issue where a copyholder, although being recalled/opened by a layout, can’t, on the other hand, be closed by another layout.

So what I am saying is that if you have stored a layout that contains a copyholder, going to that layout works fine (opening/displaying the copyholder in the right place, but going then to another layout that is without a copyholder, the copyholder ends up taking the editor’s place.)

I can confirm the first part of your bug report here. I made a similar observation (along with others) back in the beta stage. The top/bottom controls did not save properly and reset on close to the 50/50 split as noted. I think after that the built-in layouts were hidden - still needed work.
The second part is also true, though it was not noted back then. That is less than optimal, but goes along with the first part.

Thanks Jestar.

And if I may bring a little something extra to the attention of @AmberV,
I was surprised that searching the manual for “Layout Manager” returned 0 results.

image

image

Perhaps it would be a good idea to include it in this exact wording in the manual, so that at least it is referenced somewhere around where the layouts themselves are addressed. (?)

Or more precisely in sub-chapter 12.3.4

Because searching for “layout” :
image
(That is otherwise, in my opinion, a bit too many references to look through.)

Agreed. Checking the Scrivener version of the manual, I found there is no document with both words (layout and manager) in it, either.

The feature is officially referred to as “Manage Layouts”, everywhere except it seems in the window title bar itself. That’s the part that should be changed.

Sure. One way or the other, it’s good all the same.
As long as it takes care of the potential confusion and the ensuing infinite despair. :wink:

Yeah, as noted by @Jestar above, this is not exclusive to Layouts either, and has been a noted problem for a long time. It frustrates me too! I have specific inspector setups depending on each project, because some use keywords and others do not, etc., and having to set that up manually over and over every single time I load a project is a pointless waste of human time.

1 Like

In the inspector under Custom metadata I would like to setup up the size of the custom metadata window to always have the same size, when I resize it and quit the program goes back to a default setting where keywords takes up most of the space.

Any ideas?

There currently is no solution for that.
Technically, it should behave as you described it.
But yet it doesn’t. Will most likely be fixed eventually.

  • Open the program. The Inspector panel has Notes selected, with Synopsis taking up approx 60% of the panel and Notes 40%.
  • Change the Inspector panel layout by sliding the divider, to approx 90% / 10% split.
  • Close the program.
  • Open the program. The Inspector panel is divided 60% / 40% again.
    This happens with multiple projects. Presumably Scrivener should remember the 90% / 10% layout.

Suggest

  1. Set layout the way you want and distribute editor and inspector realestate the way you want.
  2. go Windows>Layout Manager this opens interface
  3. Add new Layout which uses current configuration and give it a name and use for system and see if this holds.

see pic.
layout

Thanks, it might do, but it’s easier just to change the Inspector layout on each session.
The point of reporting the bug (if it is one) is to avoid this inconvenience.

If you save your prefs, does the splitter stay in place after restart?

It turns out this is a known issue - see above.

I don’t see options to vertically lock-in size of the Keywords pane (I choose a smaller size as I have few keywords and lots of metadata fields. When I exit Scrivener, which autosaves, the app does not remember the size of the Keywords pane when I open it again, only that it was opened, but now it opens over my metadata.
Equally so, the Project Bookmarks and Document Bookmarks, of which I regularly have up to 10 items, since it’s the quickest way to work outside of the manuscript (through quick reference panes) – besides linking to material outside of Scrivener – without having to leave whatever I’m busy with. It appears locked to display a maximum of 7 item, else I need to scroll.
A minor quibble, but it would be aesthetically pleasing if these were options under a user’s control.

Thanks simeva et al.; here’s what I drafted before I found this thread.

It seems that since my 3.1.3 (x64) update, the editors’ Inspector sidebar presents the boundary between the Synopsis and Notes far down the sidebar; 80/20%? (My usual view is the ‘default’, about the reverse 20/80.)
– I ‘never’ (ie, extremely rarely) play with that for either of the editors.
(I do play with the QR view’s divider.)

It’s ‘good’ to know that folks are thinking about this.

(‘Speaking’ of the QR views, it would be nice were there a keystroke, menu-pathed or otherwise, to revert to the full text, ‘editor only’ view.)

Win 11 x64; i7, 32GB 2T (SSS, loath to say ‘drive’)

Could you be more specific?

If you mean “toggle on/off the format bar”, then Alt + V + E + B does that.

Best,
Jim

Thanks Jim,

My practice is to have the QR open in ‘editor only’ form; none of the Inspector items visible (at the bottom).
When I want to see one of the items, I display it either by clicking on the menu at the end of the Format bar or by Alt+N+I+whatever.

With, say, the Synopsis panel opened at the bottom of the QR, if I do Alt+V+E+B, the Format bar comes or goes, but the synopsis panel remains.
What I think I would like is a keystroke path like Alt+N+I+E(ditor only)?

(A digression: There is a thing about the bar implementation in the QR that allows the Insert horizontal centered line to work that does not work in the main window—but that is, for me, for another time. (It may even have been addressed an update or two ago.))

Ah, I see what you mean. Yes, with the current implementation it will take 2 steps.

  1. Alt+V+E+B to toggle Format bar.

  2. Alt + V + L to toggle the editor split setting. If you want to remove the split, then you can just hit enter, otherwise you need to arrow down–for some reason, these menu items don’t have shortcuts.

Best,
Jim

Yes, Jim; I see.
Thanks; that’ll do it.

View, Inspect; I’ll need to think a millisecond or two between the two paths, despite their related end purposes.

g

1 Like