Learned words[BUG LOGGED]

Well, the dictionary keeps getting better and better, which is a good thing! However, there is still at least one major glitch that I’ve noticed (like, five minutes after 1.6 is release. I should be doing my homework, but…).

When I right-click a word I want to learn and click the learn command, the word is highlighted as though I selected it, but it doesn’t appear to be learned. I can do this to several words and always get the same result: highlighted, but not learned. If I exit the project and then immediately pull it up again, the words I “learned” are no longer underlined, and would appear to be in my dictionary. However, if I right-click a new word and hit learn, all my previously learned words get underlined in red again. It seems as though learning between sessions causes all learned words to be forgotten.

Rephrased, because sometimes I don’t make sense: In theory, if I went through my document and added all the misspelled words to my dictionary and then closed and reopened my project, I could move on without the words popping up as spelling errors. If I later try to learn a new word in a different session, though, all my learned words are forgotten.

(Rephrased again, in the form of the steps I took, just in case:

  1. Open project A

  2. Learn words (red underlining does not disappear; word is highlighted as though selected)

  3. Exit program

  4. Relaunch project A

  5. Learned words do not show up as spelling errors; they appear to be learned

  6. Ask the dictionary to learn a new word

  7. All learned words in project A are forgotten and are underlined in red)

I love the new release; mostly it’s beautiful! I’m going to keep exploring it, in the hopes that the dictionary error is with me and not the program.

I’m running Windows 7, if that matters.



Bah! You beat me to reporting this one, but I was only going to post about the “Learn Spelling” function not working properly when I right-click on an underlined word. Good to know I’m not the only one experiencing this problem. :slight_smile:

I, too, am running Windows 7 (64-bit, mind you) if it helps any.

I have the same issue. I use Windows 7 64-bit. Rats. I love Scrivener and was eagerly awaiting the fix for the learned spelling bug in the last beta.

This is more serious than the last bug. With that one, Scrivener at least learned spellings for the duration of a session, even if it had to be taught them again during the next session.

Now it discards all previous spellings during a session every time it’s necessary to teach it a new word.

As a “three thumbed” typist, one of the greatest things about Scrivener is its enormous autocorrect dictionary and abilikty to ciorreect mistypings as I write so I don’t lose my flow because of endless backspacing. Please, please, see if this bug can be fixed quickly as it is central to using this wonderful editor.


I confirm this problem under Win 7 with the French dictionary.

New words added to dictionary will remain underlined in red during the active session.

But here, they stay underlinded after closing and reopening the project.

Windows 64-bit here also. With exactly the same issue as described in the first post.

One of my characters has a name which is auto corrected rather amusingly (and rather distractingly) every time I type it.

Still everything so far seems great. Thanks for the effort the devs have put in.

Same issue… Windows 7/64…

Yep, same here with windows version and WINE and also with the linux native version. (So it’s not a 64 bit problem, since I’m not running a 64 bit distro.)

Same problem and I’m running on Vista.

Same problem on Win 7 Ultimate 64 bit (desktop) and 32 bit (netbook).

Same problem using Win XP too.

I’ve noticed that the word remains underlined after informing Scrivener to learn the word, as well. This hadn’t been an issue before for me, but has come up with beta 1.6. However, instead of completely restarting the client, you can just right-click and select “Recheck spelling” from the spelling menu. The underlining should disappear from that particular word. A funny little side-problem is that when I asked Scrivener to learn a second word, the previous word became underlined again. But again, the recheck spelling function removed the underlining.

I’d suggest using that until it gets fixed instead of restarting everything. Hope that helps a bit!

Same here.

When I draw up my personal word list it’s empty – it’s as if I never taught the dictionary words.

Win 7

Me too. The little squiggly red line never vanishes.

No doubt there’s a bug here, but I’ve not been able to duplicate this. I’ve uploaded a short video of me using this feature in beta 1.6 just to make sure I’m not doing any you all aren’t - I doubt this is the case but we need to start somewhere resolving this. I’ve been stumped a few times this week already with permissions issues, maybe this is another one - but if it’s happening on Linux as well then I’m not sure. However, because we write theses word lists out to a file within Scrivener it still might be the case?

Spelling.swf (3.56 MB)
This is a Flash SWF file which can be played by a standard Flash Player Plug-in for Browsers


It’s been confirmed that there were several users who had permission issues installing Beta 1.6. I did make several changes in the installer around permissions to enable the live-update code for when we finally drop it in and prevent all this installation madness.

I was just thinking that if someone wants to download the updated 1.6 beta installer and see if the learning words issue still persists?

If it does then we can rule out permissions as well. If it fixes it, then a simple re-installer is all that will be required - wishful thinking on my part.

Let me know how you go.


I just tried it on my Asus eee netbook, and it learns the words and appears in my personal word list, but the red underline is still there. I’m running Windows 7 Starter

Hi Lee,

I uninstalled everything, checked for anything that hid, and then downloaded again using your new link. The same problem is happening. And I can confirm that if you learn words, exit, reopen the project, learn a new word, and then tell the program to re-check spelling that the underlines go away.

It also works if you don’t close the program: Learn a word and nothing happens. If you then tell the program to re-check spelling, the underlining goes away. Any additional words you learn cause all the red to come back, but recheck spelling will make them go away again. It’s almost like the part of the dictionary that learns words is having a hard time communicating with the spell checker, if that makes sense. If I force them to exchange information via restarting the program or rechecking spelling, the error goes away. But if I just interact with the spell check, it doesn’t look for or otherwise see the learned words.

I hope that helps a little!


Yep. Doing it for me on both Linux native and windows versions. (This is with the new windows installer. I’m not sure how privs are inherited between linux and wine.)

I’ll learn a word, and it’ll remain underlined. Then when I recheck spelling, it’ll be not underlined, as it should be.

I’ll learn a new word, and the first word will be underlined, as if it were misspelled.

Recheck spelling, and neither word are underlined.

Exit the program, open it, and both words are not underlined.

I’m also seeing the spelling issue even after the new installer. Should we do some kind of manual removal of Scrivener to make sure no leftover files/folders with potential security issues could be the problem here?

I successfully managed to reproduce this on a freshly installed XP machine today. So, we’ll fix it.