Leopard and statistics.

Hi, I just installed Leopard and it looks cool but now when I try to check statistics freezes and I have to force quit. Is that a known issue with Leopard? Thanks.

Disregard, my bust, I didn’t let it tun long enough, what with almost 2000 pages.


A project word count crashes my document with only around 25,000 words in it. I get a not responding message and have to force quit. Have left it running for two minutes (Leopard, Macbook) but no luck. Crash report attached if it’s any use.
crash.txt (123 KB)

I have the same problem with Tiger 10.4.8. When several documents are selected and the Statistics window is invoked, the colored ball stays spinning forever. I must force quit, since the application “is not reponding”.

Selected documents are a mix of simple files, groups of files, and folders. Selecting less of them do not cause the crash, even if they are still of a mixed type.

This did not happen with 1.09b (never tried with 1.095b). I cannot find any report in the Console, nor under Scrivener.crash.log, or under console.log or other reports I’m looking into. Is there any other place too look at?

Keith, I can send you the project I’m working on, in case you can check for it. Just let me know.

Also, is it safe reading 1.1 projects with version 1.09b? I would like to go back with it for a while, since I’m using the Statistics function a lot these days.


Well, as a test I let the SBOD (spinning beach-ball of death) spin for about fifteen minutes and did other things and came back to it and what do ya know? It worked! It took a while because the project was so large but it worked.

I can try to let it spin on my 12,000 word project, and see if it does the same here. However, I can confirm that 1.09b is working fine and fast on the same project.


I cannot even begin to tell you how gutted I am about this.

I have spent literally weeks trying to fix this bug. It is caused by the widows and orphans code. Because of an earlier fix to get rid of this crash, there was another bug whereby the widows and orphans code would only fix the first widow or orphan. I found this bug in 1.095b. So I fixed it for 1.10, but this must be what is causing the hang/crash.

I can’t reproduce this, so I really need a project which exhibits this behaviour as soon as possible so that I can fix it for 1.11.

I may have to get rid of widows and orphans fixing completely.

I want to scream. Or shoot myself.


Whoa there little pilgrim! Kill yourself over something so trivial as this? Harsh words my friend. Besides, where we be without your knowledge and support. I know it must have been tough being a former programmer myself it can be very tedious chasing down every bug.

BTW, do you know where the term bug came from? I forget her name, but she was a Naval woman who ran that behemoth ENIAC with all those open air chattering relays. Well one day a moth got stuck in a relay arm while they were running ballistics for the navy guns and when they found it they taped it to an old yellow legal pad of paper describing what happened. It is still viewable in the computer museum in Boston, MA. I have a book on it too. Pretty wild how it came into our lexicon. Those old room sized monsters had to be HARD WIRED to program, so you think you have it tough? Anyway Keith, you’ll figure it out then it will be an “aha” moment. Good luck.

That was Grace Hopper. Saw her interviewed years ago at a very advanced age. She was a hoot and damn smart, too.


Bingo! What a smart woman she was. What a cool story.

I can reproduce this bug, too. Please let me know if you still need a project that is able to trigger the crash. It only happens, when several files / folders are selected, never happens doing the full word count.

edit: trigger the crash, not trigger the trash …

Thanks, but I am going to ignore it for now. Keith is smart enough to eventually figure it out.

Actually, I was asking Keith if he needed a project to figure out how the bug works :wink:

(I think it’s the first time in my life I use an »emoticon«)


NO! NO! Well, at least, not until you have fixed that bug…


In your own time, Keith. It ain’t a huge deal compared to all the plus points you’ve delivered us…

I can see that problem with FAQ.scriv.
Waiting… Ten minutes MORE…
Ten minutes LATER: I give up… Force quit.
Load again…
And now 5 minutes more with:
“Synchronizing Search Strings…”
CrashScrivener.rtf.zip (15.2 KB)

As previously, you can turn off widows and orphans avoidance via Page Setup to stop the bug occurring for now…

sigh Another whole evening lost to this self-same bloody bug…

I wouldn’t blame you if you just ditched widow/orphan control entirely, to be honest. If someone really needs it that badly they can export to a word processor to take care of it.

dodges several bullets from widow/orphan activists

Agreed. Not worth all this effort. Widow/orphan control, while nice if easily achievable, seems more like a word processor/formatting thing than an info organizing feature.