"Level 3 folders and deeper" not lighting up

I’m using “Default types by structure” to assign values to indentation levels.
When I click “Root Folders,” “Level 1 folders,” and “Level 2 folders,” the appropriate folders in the Binder light up. I also created a “Level 3,” but when I click on “Level 3 folders” the corresponding folders in the Binder do not light up, even though they have the correct level value.

The first image shows when I select “Level 2 folders”; the corresponding folders in the binder are lit up.

The second image shows what happens when I click “Level 3 and deeper.” Nothing lights up in the Binder.
The inset in the upper left corner shows that the correct type “Section” has been assigned - in this case, using “Main Interface” as the example, when checking in the Inspector. But in the Binder - nothing!

Am I doing something wrong? Is there a limit to how many levels of folders Scrivener will accept?
Thanks!

Hi.

It works for me.

Make sure your folder isn’t a level 4 or other than level 3.

From your screenshot: Your “folder” is actually a file group, not a folder.

image

True. But I’m having the same issue with all the other items at the same level of indentation

Your screenshot only shows files.

So the plus sign generates “Level X and deeper,” but when lighting up, it goes to an exact level, rather than “level X and deeper.”

How do I discover what level a folder really is (other than by looking at the display in Binder)?

Ah. I guess this means that individual files can’t be assigned to a level. Is that right?

You can set them all the very same way.

They need to be set like this in the metadata,
image
else, they will light up, but they won’t obey the alternative setting at compile.

Thanks for your input. Gotta go now (spouse calling). But I will try again, with a fresh project created from scratch and see what I can figure out.

1 Like

It looks like you are using the tutorial for your screenshot.

Level 3+ FOLDERS will only “light up” if they exist in the project. There are no folders at level 3+ in your image. I’m not at my computer to check if any exist further down the page in the tutorial.

What happens if you click on “all file groups” further down the “Default type by structure” list? Do they “light up” now?

Thank you everybody! I see that I had no level 3 folders. Everything lower than a level 2 folder was either a “File” or a “File Group.” What threw me was the notion that “files are folders and folders are files,” which receives great emphasis in the tutorial. Section 7.3 of the Manual outlines exceptions to this general principal. Also, the text “Document type and outline level” is a bit hazy, insofar as the distinction between folders and files. So I failed to catch the fact that my Files and File groups are not going to behave the same way (i.e. light up) as Folders in this instance.

Screen shot 1: The mystery explained: No level three folders exist

Screen shot 2: I created a level 3 folder, and it dutifully lights up when I select “Level 3 folders & deeper”

Screen shot 3: I created a new default type (“Text”) in the Inspector, and assigned it to the files and file groups furthest down on the tree.

Screen shot 4: When I select “All files,” all the Text files light up

Screen shot 5: Finally, just for good measure, I went into Outline view and sure enough, all is well. The default type “Subdocuments” to Test Folder is supposed to be “Text,” and it is.

I think I have it now. If I’m still mistaken or missing something, please let me know.
Thanks again, all who have responded.

4 Likes

Thanks! See my detailed response, above.

1 Like

You:re welcome! I’m so glad you figured it out!Great explanation and screenshots btw! That will certainly help others down the road! :blush:

2 Likes