[LH1853] Bug: Footnotes do not expand properly after being collapsed.

Beta version number. 2.9.0.32
Windows version: Windows 10 pro v1809

Open the footnotes & Comments section in the sidebar.
Select an open footnote and collapse it,
Expand the footnote. The footnote remains only one line high.
If you switch between pages, all opened footnotes are properly epxanded again.

I just noticed that this still happens in B35. If you collapse a footnote, then reopen it, you see this:

screenshot.jpg

You have to switch to a different document, then back to the original to see the full note again:

screenshot2.jpg

Just checked—there seems to be no any problem with folding-unfolding footnotes in my project (B35).

Very odd. Made me wonder whether I’d inherited some strange problem from having created the project with 1.9, then kept it going through numerous betas. So, I started a brand new, blank project with B35. Just Typed “here is some text. And here is the footnote”. Cut and paste “And here is the footnote” into a footnote, collapsed it, restored it and found exactly the same problem as originally reported. So, really strange that you’re not seeing it.

I have just checked once again (sorry for a delay). No problem—I folded a one-line footnote, and two-line, and some rather extensive ones, but in all cases I could see full text without any cropping after the footnote was unfolded. I would only recommend to try (radical) changing font and font-size in the settings to see if there is some connection here.

jje, here is sort of a confirmation: B35 seems to work smoothly with unfolding my footnotes:

scriv_footnote_folded.png
scriv_footnote_unfolded.png

In B38 not only is this not fixed, but all my footnotes are now “collapsed” and cannot be expanded:

This problem seems worse than ever in B39. When I add a new footnote to my project it is “pre-collapsed” and doesn’t expand as I type, so that I can’t see what I’m typing:

I’m guessing this is caused by the sheer number of footnotes (there’s no easy way of counting them, but there are several screenfuls for this 7,000 word document)? The earlier footnotes display correctly:

As I said, if I type into the “collapsed” footnote, it doesn’t expand, but when I paste text it does:

Thank you guys! This was a long standing issue, but I am glad to tell that the Inspector notes visualization has been fixed and pimped in the next Beta 40 update. Let me know how it works for you once released.

Can’t wait! (Sad, but true --spot the academic :cry:)

Thanks

This has never happened to me, even though I use footnotes extensively. Anyway, really glad. And, jje, my sincere congratulations—there is hardly any more important feature than footnotes for an academic writer. ) …And congratulations to the devs, of course.

Just been doing some testing in B40 and am happy to report that everything appears to be fixed: footnotes aren’t pre-collapsed, the expand and collapse properly and the “disappearing X” (the delete footnote icon that used to get hidden on the right-hand edge of the inspector) is fixed. Also, text re-flows properly when the width of the Inspector panel is changed.

Many thanks for the speedy and successful fix!