[LH2741] Can not have 2 document windows open and work.

I have 2 document windows open often (one with notes or a character list). With the new beta, I can only see the first thing that opens. Selecting another text section from the binder does nothing.

If I go back to 1 document window it all works as it should.

Seth

I’ve run into this too, since I work with split screen a lot. However, I believe this is the bug mentioned in the release notes:

Usually a resizing of the editor(via the Binder splitter) or the Scrivener window, will make the text reappear.

No, this is definitely not the bug mentioned. There is no vanishing text, but just no reaction to clicking a file in the Binder, when working in split mode.
It works, if you right-click the file in binder, choose “open … in different editor” and it will react as expected.
But of course it takes you three clicks instead of one …

Alt+Click inside the Binder will load the document inside the other editor. Does this work as expected for you guys? I could not reproduce your issue unfortunately.

yes, this is working for me.
But without the “Alt”, nothing happens.

I think this is just a non-intuitive change to old behavior.

It took me a while to figure out how to open documents in the two windows, and it’s not as intuitive or as fast as it was in Version 1. Maybe I’ll get used to this, maybe not.

I hope this isn’t intended behavior!

For clarification - when selecting a document from the binder, it only takes a single click to change the document in the editor window. If in split-screen mode, single clicking no longer changes the document visible in the currently selected editor window - it does nothing at all. Scrivener 1.x-2.x behavior was that any time a document or file was chosen from the binder, it would replace what was in the active editor window. I have a feeling this is indeed a bug, as it doesn’t make sense to change this behavior otherwise. Can anyone with the OS X edition tell us if it still functions as it did in the previous versions?

I’m becoming more and more convinced this is a bug. I’m having all kinds of trouble getting the right document to open in the right window no matter what I do.

I’m going to try in a single window or at least, one of the other layouts to see if it’s still an issue.

Of course it is a Bug: the Mac version works as expected. No new behaviour in Binder :wink:

Thank you for confirming!

Could you check that Navigate > Binder Selection Affects is set to “Current Editor”? If that is selected, this should be working as expected: clicking an item in the binder loads it in the focussed editor, i.e. the last one you clicked into, the same as previous versions.
There is a bug here with the UI display in that the blue editor header should be indicating the editor that takes the binder action (with the blue underline indicating the focussed editor) but currently that’s always applying to the focussed editor.

Ah, that’s got it!

Thanks!

Great, glad that solved it. Could you tell me, was this in a new blank project, or from one of the templates, or an upgraded 1.x project? The default setting for new projects should be to have the binder affect the current editor, and as I’m assuming you didn’t change this, it sounds like it may be getting set wrong in an upgrade. (All the templates are still the 1.9,7 format, so they’d suffer the same issue as any other project being updated.)

If this was an upgraded project, could you check the original (the backup copy made when you updated) and let me know how it was set under View > Binder Affects in 1.9.7?

I can confirm two projects (one a new project created from a 1.9.7 project template; one is my own work previously created in 1.9.7) both have the “Binder Selection Affects” set to “None” after upgrading to 2.9.0.1. A new S3 project from the “blank” template has it set correctly as “current editor”. Seems like an upgrade issue; I see another report of this issue here: [url][LH2741] Clicking Between Documents in the Binder re Editor View]

I accidentally overwrote 1.9.7 in my install (didn’t create a new install location, just went to the default) so I don’t have the old version to double check, but I recall 1.9.7 never had this issue. So I assume 1.9.7 always had the navigation as “current editor.”

Thanks for checking. 1.9.7 and 3.0 both use “Current Editor” as the default setting for Binder Affects, but 3.0 has added some additional options (None and Both), so it seems somewhere that’s getting triggered incorrectly in an upgrade. I’ve filed the bug.

Yargh. Just ran into this one tonight, as well. Good to know it’s a feature, not a bug. :slight_smile:

I’ve got the same problem, but can’t find a fix.

I installed the Beta, opened it and then tried to access an existing Anthology.

the file showed up in Explorer and even the title appeared in the listing. But nothing, NOTHING in the editor window. Trying all the helps, tips and tricks on this thread and nothing has worked yet.

So, how do I get to my anthology?

EDIT: I should add that SOME of the documents appear in the editor, just not all of them. Any thoughts?

I can confirm as well: I upgraded a project from 1.9 and it was set to “none” in “Navigate - Binder Selection Affects”.
Controlling my project in 1.9 showed the correct setting (View - Binder affects - current editor)

When I use the Layout>“Outline Left, the Outline Results Right”, and click on a document in the Left Editor, the document does NOT show up in the Right Editor as it always has.

I’ve tried everything I can think of but nothing works.

Am I missing something obvious?