[LH2754] - unable to minimize windows too large for screen

I’m using Scrivener on a laptop, and I use either the laptop monitor or connect to a large screen. Both screens have different resolutions. With the laptop monitor, some windows are too big for the screen (for example, the ‘options’, screen), but I can’t minimize it or move it up, I can only move it down.

Hello! By ‘move it up’ do you mean change the position of the window on your desktop? Or make the window smaller by raising the bottom bar?

Thank you!

I have the same problem. I can’t resize the window or push the window toward the top of the screen. The result is that I can’t see or access the “OK” or “Cancel” buttons at the bottom. Short solution is to auto-hide the taskbar. Less than ideal.

Hi,
same problem here with Scrievener set to high DPI mode. I use a laptop with a 1920x1080 resolution and the current Scrivener beta and I can’t properly reach OK, Cancel or Apply in the options panel.

The ‘low dpi’ toolbar icons seem imho a bit too small for 1920x1080 and the ‘high dpi’ ones a teensy bit too big.

I installed the beta yesterday and I love it. I have been using Scrivener (win) for five years for academic research.

Cheers,
mkk

This also happens to me on a 1920x1080 monitor when I have the desktop scaled up (and I can’t imagine using Windows without scaling it up). The options window is too tall to click Okay, and trying to resize it causes it to vanish altogether. I’m having to navigate by keyboard to Okay blindly to use the options at all.

What computer hardware are you using? We’ve seen a particular issue of Scrivener scaling incorrectly on ZenBooks, causing everything to just be too large as you’re describing. Unfortunately this seems to be a bug with the framework Scrivener is built on and we haven’t so far found a way to work around it–switching off “Enable High DPI mode” in Options > General may help, but will affect scaling in other ways, so isn’t a perfect solution, as mkk noted.

I’m using a Zenbook UX305LA.
Cheers,
mkk

I’m using a desktop I built myself, and a Surface Pro 3, which both have the same issue.

I’m having this issue as well. l have just bought a Surface Pro and am in the process of setting everything up on it. Every other program /app I have installed has been absolutely fine until I tried installing the Scrivener beta. I cannot find anyway of resizing or moving the window. I have tried reducing the size of all text, icons etc in the Windows settings, but that doesn’t help. Edit : I have also tried disabling the scaling option as mentioned above, which just made the icons blurry without reducing the size of the text or the window… Please find a fix for this, as one of the main reasons for buying this was for using Scrivener and as it stands the program is unusable…

Re-upping this thread since I just encountered this on a Lenovo Yoga book. The screen scaling was set to 150% on a 10inch 1080 screen, and the dialog window to start/open a new project was unusable with the buttons off the bottom of the display.

I know you said it’s a flaw in the framework you’re using, and this may be a longer-term problem until that’s addressed, but I just wanted to bring attention back to it.

150% scaling at 1080px height means ~540px scaled screen height. Obviously this height is too small for Scrivener. We design our desktop GUIs for at least 1080px screens at 100% scaling. Please, consider using 100% OS scaling and use the Scrivener editor zooming features. I am afraid Scrivener is a Desktop application and is not optimized for Tablet size PCs.

Well, I use a widescreen desptop and I have the same problem. And I’m afraid I’m not optimized to use 100% scaling because then I can’t read the text at all and the buttons become so small it’s difficult to get the cursor on them. There are people with eyesight that requires scaling.

It’s a major problem with widescreen computers used at recommended resolutions. I use a 24in widescreen and the recommended resolution is 1920x1080 . This is what the text looks like at 100% of the recommended resolution.

I have to use 150% scaling or I can’t read it at all and when I update the beta versions, I have to change the resolution because even moving the taskbar out of the way doesn’t allow for access to the buttons. For those, it’s point and hope I can hit the buttons because I can barely see them. And that’s with my glasses on.

If the top of the popup window didn’t stay docked to the top of the screen, we could simply move it up until the buttons were accessible…or if the popup windows were responsive, we could resize them wider and have access to the buttons.

The upshot is this, rescaling to 100% renders the program unusable for me. Changing the resolution on my computer from the recommended resolution to one that fits the program renders other programs unusable to me because the recommended one is the only one that keeps my entire screen viewable in EVERY other program I use.

So, here we are, and as much as I love Scrivener, I will find a workaround to the problem by temporarily changing resolutions entirely when I need to compile. For how long until that becomes too annoying to deal with, I can’t say. There are other programs, I don’t love any of the ones I’ve tried, but there’s probably going to come a tipping point where the love is outweighed by the annoyance.

@LauraV: You may also try to uncheck File > Options > “Enable HighDPI mode” as your monitor is most likely not a high DPI one. As much as I see from the screenshots 100% is the recommended scaling of your monitor, but not suitable to you. Unfortunately due to the big amount of compile options inside the Compile Settings view, we cannot make the window shorter in height. We either have to remove some options to adjust for users with screen sizes ~540px, which is less common nowadays, or the user will need a monitor with bigger resolution, if the monitor resolution after scaling is less than 1080px. 1080px vertical resolution is pretty standard these days and the prices of these monitors are also very acceptable. I hope you do not get my message wrong. For Scrivener to be feature rich, you will also need the screen size to accommodate for these options. If you scale your monitor resolution too much, Scrivener can not do much about it.

Many Thanks, I had the same resizing problem on Compile and New project form; unchecking Enable HighDPI mode setting, the problem seems solved.

P.S. I have a HP Probook 440 g4, 14" display with 1920x1080 resolution, and I always work with 125%-150% magnification.

It’s high DPI those weren’t screenshots, they were pics taken with my phone at a low resolution. I am not using custom scaling, I am using text scaling (these things are different) to 150% on a 24" widescreen monitor set to the recommended resolution of 1920x1080.

I only took the photos to see if I could show how small the text was at 100% text scaling. It is extremely small. The difference between 100% text scaling and 150% text scaling is huge.

I’ve already tested changing the DPI setting inside Scrivener and it made no difference because DPI is not the problem… The only thing that does work is to REDUCE the resolution which alters the wide screen capabilities to the point of making other programs look hideous OR to remove the text scaling which renders Scrivener unreadable. I have tried all of the resolution options, but because I also use Photoshop extensively (yes, I am a visual artist despite needing large text in order to read), I prefer to use the most accurate resolution for this monitor’s screen size. Which is, as I have pointed out, 1920x1080. I’ve tested every resolution on the list to see if I could find one that retained wide screen capabilities and allowed for 100% text scaling without making programs look skewed. Turns out there’s a reason why 1920x1080 is the recommended resolution and the rest are not. If I could read text at that resolution I would, but sadly, I cannot.


What I was trying to show with those photos was the difference in text sizes. Maybe this will help. Keep in mind that these are NOT screenshots, they are photos taken with my phone so they are going to show aliasing. And yeah, they’re upside down. Sorry.


That’s the problem with high DPI combined with the widescreen format. OK for images, good for films and videos but generally poor for productivity and reading text.
That’s the reason I went out of my way to find 1920x1200 monitors.
Only solution I can think of is using the magnifier, It would work, but is hardly an ideal solution.

I leave the 100% scaling for Windows, and change the zoom level in my programs. For Web browsing my default zoom is 130%. For Scrivener it is 125% but in my current project at the moment I’m using 150%. Other programs allow a “Large Fonts” option.

Windows is simply vary bad at adjusting windows for different size screens. You can usually get away with 125% increase or zoom in most programs, but 150% will knock you sooner or later.

Yeah, I’ve tried a few things to see if I could manage and yeah, making the font larger helps, but at 100%, I can’t see most of the UI.

The widescreen is fantastic though, for working in Photoshop because that program is more responsive in terms of the UI. I have plenty of room for the toolbars and for the work. I still have trouble with the size of the fonts on their UI, though.

It’s frustrating.

I know this might not be possible given your space/ budget etc. But when I moved to bigger screens, still at 1920x1200 or 1920x1080, it makes all the difference. Those letters that are small on a 24" screen are much easier to read on a 27" screen. Then get another one, so you can have your browser or quick reference on one screen and the editor on the other. I mention this, but I actually was complaining about the problems with my smaller screen and a friend told me to get a bigger screen. It had seemed like such a needless indulgence that I hadn’t even really considered it.

So, I do know of one person, who could have done it and didn’t just because it seemed too extravagant. When I made the change, I was VERY glad.