[LH2761|LH3039] Inconsistent spacing between and

I use 1.2x spacing when typing in Scrivener. However, this spacing appears to have been altered.

A document created in 2902:

A document created in 2903 in same project:

Because the project is converted from 1.x. I created a test project. Formatting is 1.2x according to paragraph setting s but change is not being shown in formatting bar.

2903 Spacing New Project.jpg

To reproduce:

Take a converted project from 1.x.

Set line spacing to 1.2.

Edit: A workaround is to type text into scratchpad and use copy to menu option in scratchpad. Setting to 1.2 linespacing works as intended when copying from scratchpad.

Has this issue been logged please?

The bug whereby the spacing dialog and the format bar aren’t correctly meshing up to show the proper line spacing is logged, and I’m sure that’s complicating the other issue, but I’m not able to reproduce the issue of the 1.2 line spacing being radically different between documents. My guess is that it’s just using a different line spacing and because of the other spacing bug, it’s not reporting correctly. Is the default formatting set to use the 1.2 line spacing multiple (in Options), or are you setting this individually for documents? Do you apply it by selecting 1.2x from the dropdown menu in the format bar or only by opening the line and paragraph spacing dialog?

If you have a sample project you could zip up and attach or send to win3beta@literatureandlatte.com, that would be helpful.

1.2x spacing is document default. Tried changing it via drop down and paragraph window and get the same result. However, if I set to single line spacing and then change to 1.2x this seems to resolve the issue. The issue seems to be default spacing with new documents as I’ve just created a new document and the spacing weirdness is occuring. I’ve emailed you the project in question to the email address in your post.

Hope that helps!

Hi Stacey - I apologise for the super late response here. I’ve looked at the project and toyed with the default settings, but everything I’ve been able to reproduce at this point boils down to what seems to be the same problem with the spacing not reporting correctly in the spacing dialog or format bar. Closing and reopening the project seems to update the display in the format bar to correctly show the actual spacing of the paragraph.

I am hoping we’ll get that spacing bug fixed soon, and we’ll then be able to see if that completely resolves the problem you’re experiencing, or if there is still a lingering issue–and hopefully it will then be easier to track down.

Thanks MM for taking a look.

As of this issue seems to have resolved itself! (Yay!)

I’m facing the same problem with—and I have with every build since

In short, any spacing greater than 1.0 results in something roughly five times as much as it should be. This happens on both new and old documents as well as on Windows 10 and Windows 7.

It’s unfortunately made it impossible for me to use the beta. I had been enjoying it up until

Single Spaced

Double Spaced

Thanks for the report. We’re aware of this issue with the line spacing multiple but have yet to resolve it. If you’re using a constant font size, you could try setting the spacing via the exact height rather than a multiple; that might tide you over at least for working in the editor.

Thank you for the suggestion.