[LH2828] Accented characters add spurious spacing and switch fonts

I opened and converted a small Scrivener project created in Included were four template files. I created a new text entry from a template file. Everything so far looks fine. I use Georgia 12pt Normal as my default font and is also the Body Style. As I filled in the template, there were no problems until I added an accented character–the word château.

When I added the “â” using Alt+0226, Scrivener added varying amounts of space at the front of the paragraph, and additional space was added at the top and bottom of the paragraph. The accented character was not in Georgia font, but in Calibri 13pt, as were all characters following. I tested this several times to make sure it was consistently happening–and it is!

Now, here’s an interesting bit. If I Ctrl+A to select all the content of the errant page, create a new blank text page, and paste the content into the new text page: it looks exactly like the errant page–with extra space around the paragraph. However, if I create a new text page in Scrivener 1.9, paste the same content there, I get to see some hidden markup, as shown below.

<$Scr_Ps::0>Role: Handyman at Château Malfort.<!$Scr_Ps::0>

In this line, “Role:” is Georgia 12pt Bold; “Handyman at Ch” is in Georgia 12 pt Normal; “âteau Malfort.” is in Calibri 13 pt Normal. If a paragraph is already indented, the indent is increased substantially. You would think that a single Ctrl+Z would bring everything back, but it takes several Ctrl+Z’s to bring thing back to normal again.

As a former developer myself, I’m sure you’ll have plenty of fun with this one!

Thanks for reporting! This is a bug we’ve encountered where using the Alt key to create special characters is also causing our new “Styles” to activate. I believe the ‘Ps’ you see is Paragraph Style and End Paragraph Style. We’re working on a way around this. In the meantime you should be able to highlight the affected text and either press “Alt+0” or select “No Style” from the drop down menu just to the left of the font signifier in the editor toolbar.

Tried using Alt+0 and changing to No Style as you suggested, but neither changed anything. In fact, I could click on No Style many times, but nothing happened. It seems to be stuck on Block Quote. I can change it to another preset paragraph style, but not to No Style. Changing the paragraph style did not change the font either.

Hmm… Would you mind sending us a copy of your project to take a look at? You can email it to win3beta@literatureandlatte.com with a link to this post. That way we can take a closer look and see what’s going on.


Sorry I haven’t responded sooner. I tried this again in the latest Beta ( with the same results. I can send my project to the specified email address, As was mentioned, this is an Alt+Code issue, since all the diacriticals are OK when opened from the original 1.9 version and when pasted from Character Map. My novels contain some French and Spanish dialog, so diacritical support with the Alt key is a must.

I have tried this again with Beta 10. If I assign “No Style” to the text, I get the default text as set in Options. When I add an accented character, the paragraph style does, in fact, change, but the font does not revert to Calibri. Perhaps this is because I changed Options to have Georgia 12 pt as my default font. With è, é, and â are switching to Block Quote. If I change back to No Style, the paragraph is returned to normal without affecting any other formatting such as bold and italic.

I hope you can fix this in the final version, as it would be a pain to have to continually change the paragraph style each time I use a special character entered with the Alt key.

After installing Beta 11, the Alt+ characters appear to work fine. I wrote some new text with accented characters, with no apparent problems. The font remained the same, and no spurious spacing was added. Nice to see that fixed!