[LH2890] Very strange new Quick Search Problem in Projects that contain a script file

As far as I knew previously, Quick Search has been working fine. However today, using a script document, I noticed that I was missing some letters of the search string I typed in. The letters missing happened to be the shortcuts for the script elements. And when I type ‘ab’ into uick Search it works the way you would expect, but then typing in ‘c’ changes the element where my cursor is (which was originally the Shot element) to Character and then typing ‘d’ into the Quick Search changes the element further to Dialogue. and the ‘e’ makes it General Text (centered), then ‘f’ is entered in Quick Search and then ‘g’ turns it into General Text. And I tried a ‘u’ (which is my shortcut for Duration Element) and it turned the element where the cursor was in the document into the Duration Element.!

When I go to a normal text document (scriptwriting mode is turned off) in the same project, this is still a problem and if I type in ‘abcdefgu’ to quick search, then only ‘abf’ show in the Quick Search field. Then I went into a different project with script documents and had the problem again in terms of the letters representing the scriptwriting element shortcuts keys to be missing in the Quick Search field in exactly the same manner, but in this case it did not change the element. The element remained as the Shot Element as I cycled through the keys.

Then I went into a project without any scriptwriting documents and Quick Search worked fine and exactly as expected.

So I tried creating a new project from the screenplay template, and entered a Scene name for the first element and had the cursor positioned on Scene. Then typing in the ‘abcdefg’ sequence again, 'it showed in Quick Search as ‘abf’ but it did not change the element name.

So in one project, my element shortcut keys are changing the element name where the cursor is positioned and in two other cases it did not change the element tag. But in all three case if there was at least one scriptwriting document in the project, then the shortcut keys did not appear in the Quick Search field, even though I typed them in. And in the project with no scriptwriting documents, Quick Search worked fine and all the characters appeared in the field.

And now it gets weirder. If I have the project without a script file open and then one with the script file open, and I am active in the one without the script file, and type ‘abc’ into the Quick Search field for the project without the script file, the ‘c’ does not appear and the script element (Shot) where the cursor was last positioned in the project with the script file, that element changed from Shot to Character, even though I was typing in the other project!. And then when I went to the project with the script file, and changed the element back from Character to Shot and then closed that project, then all of a sudden the ‘c’ appeared after the ‘ab’ in the Quick Search field.

This was all done on my desktop Windows machine, so then I moved to the laptop to see what would happen and I got similar behaviours.

Then I opened the same two script projects on Mac and everything worked perfectly, making me think it is not project related.

So here are my conclusions, but you may find out something different.

  1. There is not a problem nor corruption with my Projects that contain script files because Quick Search using the text string ‘abcdefgu’ works just fine and I tried it with two different script projects as I did on Windows. (BTW, the ‘u’ is a shortcut from an element I added, not one of the 7 standard ones)

  2. In 2903, if only one project is open and it does not contain a script file, then Quick Search works fine

  3. In 2903, if there is a script project open, even if I am working in a non-script document or Folder, and type in ‘abcdefgu’ then the filed in the Quick Search displays, ‘abf’ even though all the other characters are there, they just do not display.

  4. In 2903, with both a non-script project open and a script project open, and typing in the Quick Search field in the non-script project, once I hit and type in several of the shortcut keys, that the element I had last selected in the other script project (and I thought non-active one) changes. When I type in the ‘c’, it changes to Character, and when I type in the ‘d’, it changes to Dialog.

I am really gobsmacked. I have used Quick Search so little prior to this and maybe the text string I typed in did not have any shortcut keys, so I cannot be certain if this has always existed or if it is new. But if new, why is it not a problem on my Mac? However, I think it must be knew as I probably have type in an ‘e’ as part of the search string before. I know this is convoluted and difficult to follow, but you should be able to easily test out if you can reproduce the problem, and if not, I can take a video of it happening to send you instead of just the screen shots and all zip up the projects for you. But it even occurred on a newly created project. Sorry this one is such a niggly one. At least I can reproduce it and the behaviour is consistent.

Sorry, to make things a little messier, sometimes an ‘a’ does and does not appear, and sometimes an ‘e’ does and not appear. If I type in an ‘e’ as the first character, then it displays in the Quick Search field, but if I type in ‘ee’, then the first ‘e’ is displayed and the second one is not and the element changes to General Text (centered).

I just realized that ‘a’ was the Action Element also, and if you type in one of the shortcut characters as the first character in the Quick Search field, then it is displayed, but if you type it in a second time, it does not display and changes the element tag to that element.

In general, you are able to type in any first element shortcut key and it displays and the element tag is not changed. However, when you enter a second character that represents an element shortcut key, then it is not displayed and the shortcut is applied to the element where the cursor is.

BTW, I just test this out in Project Search and everything works fine. The shortcut keys are all displaying and the search works correctly. and no elements are getting tagged with you type the same character string into Project Search. So this only happens in Quick Search on 2903.

Thanks for the detailed reports, This looks all tied to a logged bug with the script shortcut keys being triggered whenever a menu is open. In the case of the Quick Search, the search starts running pretty quickly to generate the menu, which I suspect is why initial typing when you’ve first clicked into the field works as normal, but subsequently the letters act as shortcut triggers instead of text in the field. Project Search works differently, not creating a menu as such, so the bug isn’t occurring there. But you’ll find this happens any time you have a script document open and try to use accelerator keys–if you type a letter that matches a script shortcut, it gets captured by the script document instead of working in the menu.

In the meanwhile, you’ll want to not run the Quick Search while a script document is open, or else make sure your cursor was left on an empty line at the end of the document (or just change the element back if it gets changed). Copying and pasting the search text into the field will work, too.

Great - glad you have it sourced. Good idea about copying and pasting a text string in, in the meantime. I will assume that once the Script Shortcut Key bug gets fixed, this will be fixed with it.

Should; I’ve added a note to the ticket to be sure this is tested when it gets fixed.