[LH2916] Selected Document Type and Outline Level Not being Highlighted in Binder

When I go to Project Setting and Section Types and Structure As-IS, and select a particular Document Type and Outline Level, the corresponding entries are not being highlighted in the Binder, the way they are on Mac.

Does this occur for you on at all levels or are there only particular ones that fail to highlight?

It occurs on all levels. I have moved up and down the Outline Level for Folders, File Groups and Text Files, but have not seen the Binder highlighted at all. It would seem that this would be very easy to re-produce, but if it is something I am doing or you want me to test something else out with it, let me know.

I have not been able to reproduce this yet, so something extra must be causing it. Have you set up any custom section types in this project? Is the project upgraded from the previous version? Does this issue persist in a new project as well?

Thank you for your help in tracking this down.

Good points, I should done more thorough checking on this. It was originally a 1.5.4 version project I upgraded to 2903. I will test out a couple of other projects with different legacy to see what hpaaens, including a new project. But this project in Mac 3.01 does show the highlighting. I am out now, but test in couple hours when I return home.

I tried several other projects that were created in 2903, one in 2902, and created a new project from template. None had custom sections. I added four layers to each of the Structured As-Is Folders, File Groups and Files and traversed every one. Not in one instance did I get any Binder entries highlighted. I then opened the same projects on my Windows laptop with 2903 and got exactly the same results. Then I opened all the same projects on my Mac 3.01 and every project at every level work perfectly. So I do not think it is Project related. Highlighting does not work at all for me on 2903 and its works perfectly using the same projects on the Mac.

Any other suggestions? I cannot think of any Option or Project Setting that controls this. And your telling me that you cannot reproduce it?

Last question: Can you reproduce this without first creating additional layers? In other words in a brand new project can you immediately highlight “all files” for example and still not receive any highlighting?

Thanks for all your work on this.

I just created a new project from Non-Fiction With Subheads, and did not create any drop-down levels in Structured As-Is. I clicked on all three and none of them highlighted.

Here is nothing highlighted in 2903:

And here is same project working properly on Mac 3.01

Options shouldn’t affect this, but I’d try reseting those to defaults and testing again, just in case. Save your current ones first so you can reload them after the test, and if there is a difference in the behaviour, please share the settings file with us so we can try to track down what’s causing this.

What zoom setting do you have for the Windows display scaling? Also, if you add labels to some documents and then set View > Use Label Color In > Binder and select the “Show as Background Color in Binder” option, do the labels appear as a colour bar behind the text, similar to the macOS 3.0.1 version?

Thanks. Will check out when return home in about 8 hours.

I reset Options to Default and that did not make a difference, which is good because I did not expect it to. My display Zoom size for Editor was set to 120%, and UI switched it to 100%, but that did not make a difference, which again is good as I would not expect it to.

I went to View and Set Label Color in Binder and then Set as Background Color in Binder and that worked perfectly as you would expect. All Binder entries took on the label color assigned to them. Just for fun, I also checked to see if the Selected Document Type and Outline Level highlighted the Binder entries on top of that, but they did not.

I have asked another Scrivener user to test this out on her computer also to see what results she gets, so will keep you posted on that.

I had another person test this out on Windows and the highlighting worked for them, so it must be something on my systems. I have tired the various things Jennifer suggested and none of that made a difference, plus I was able to prove adding color to my Binder entries does work. I reset al options and that did not make a difference.

I also tried this on three different display, one for my laptop and the 28 inch 4K main monitor on my desktop and tried it both at 4K resolution and 1920 x 1080 and did not get the highlights. And also tried my older second monitor which is a natural 19020 x 1080. And I have tried it across 5 or 6 different projects, having upgraded from 1.9.7, created new in 2903, etc.

I am not aware of any Windows 10 settings that may be causing this or my NVIDIA Card drivers which are current. Plus I still find it strange that the highlights for this do not work, but all the other stuff that colors the Binder entries does.

Not sure if you have any other suggestions or not.

I also uninstalled Scrivener 2903 and re-installed the 32-bit version to try it out with no luck and then re-installed the 64-bit version and it still does not work. I am grasping at straws here, so will look for any suggestions you may have.

I have Windows installed on a Desktop and a laptop, both current Windows 1709. I just installed Scrivener 2903 64-bit on my wife’s computer which has a different and slightly old chip set, so she has Windows 10 1607 with different monitor type and graphic card… I run into the exact same problem of not getting the highlights in binder for the respective section type. I did notice when I open the same project on the Mac and it worked that Structure-Based had a checkmark to the left of it (which you would expect since I checked it. But it does not have a check mark next to it when opened in Windows even though I have checked it. Not sure if that is an issue.

I have not run in Safe Mode and must admit I am a bit reluctant to completely re-install Windows as everything else works within Scrivener, all my complex Adobe Apps run great, etc. This just does not look like a driver problem or firewall problem to me. It looks like I have not set a View option correct or something like that. But I have installed this on three different PCs with different displays, graphic cards and slightly different versions of Windows and it and all other functions perform exactly the same regardless of PC, and the same projects work fine on the Mac.

Could you please zip up and send a sample project demonstrating this to win3beta@literatureandlatte.com? Thanks.


I have forwarded Zipped project made this morning from 2903 Non-Fiction with Sub-Heads template and then duplicated Folder a couple of times and renamed to Chapters 1,2,3. Then checked Structure As-Is and selected All folders.

Here are screenshots.

Sorry about this issue as it appears I am only one getting it and may be a problem on my side.

Thanks. The project is showing the section highlighting fine on my Windows 10 environment, so it doesn’t seem to be anything problematic with the project-specific settings. If you’ve already tried setting the program settings to defaults, I do think at least testing by rebooting into Safe Mode would be worthwhile. After the test, just reboot normally.

I was not thinking it would be project-related as it has occurred in every project and works OK on Mac. I have reset Options, but will do so again. and then Safe Boot. What do I do in Safe Boot though? It looks like it wants me to Recover or Re-install and I am not sure what steps to take?

Also, what is happening with this thread? Has it gone private? I cannot see my last two or your last post?

Sorry! My mistake as I see it has just fallen over onto next page!