[LH2937] Text Document Title defaults to entire content of document.

In version 1 (Windows) I found that if I left the title field of a document blank it was filled with the first few words of the document content. I find this useful when looking for a particular document to check or edit.

I brought a novel into version 3 and saw the document titles as before. However, in some cases, I had provided a specific title and deleted it. On closing, the document title now showed the entire content text of the document (in italics). This text also appears in its entirety in the content column of the outline.

My workaround is to copy and paste the first few words of text into the title field. I don’t know if the default titles in version 1 were dynamic (i.e. represented the state of the first few words actually in the document when it was last closed) but if not that would be, for me, a useful improvement.

Hi John,

In version 3, documents with no Title will use the first 75 characters of the document’s synopsis as a default Title. If there is no Synopsis, the first 200 characters will be used for a default Synopsis, and the first 75 characters of those will be used for the Title. This updates each time the document is loaded. This is a new function to allow for more outliner options.

Is this what you are experiencing? Or are the Titles and Synopses not cutting off after 200 characters?

I think that is what is happening. Where there is no title, it is made up from the beginning of the text. When I select view-outliner columns and do not select synopsis, I see the default (first of text) synopsis but not the title. Why not show the default title in this case? Surely the time to see the longer text there would be when synopsis is chosen in the outliner commands?

You are correct. When Synopsis is not chosen it should be showing the shorter default Title, which is the same as the default Synopsis but less than half as long. This has been filed.

Thank you!