[LH2961] : Words marked as mis-spelled before they have been completed

While Check Spelling as you Type is turned on, some words are marked (with squiggly red underline) as mis-spelled before they have been completed (no space, punctuation, or return has been added yet). Once completed the squiggly red underline disappears.



This bug appears in all documents I am working with, and reappears if I save and close Scrivener, then re-open in the same document.

I feel for you! I’ve had my arm twisted to take on a job which means I have to use Microsoft Word for Mac … and it does exactly the same thing!

:laughing:

Mark

That’s not good news. MS for Windows (at least Office 2010) doesn’t do that. If the Scrivener developers want to make their product for Windows as close to the Mac version, then I suppose this isn’t a bug at all. But I cannot understand how this would be the preferred behaviour. I suppose I’ll just have to turn off check spelling as you type.. IMO, the method of marking misspelled words while you type should be selectable.

I can’t speak for the developers of Scrivener on either platform, being merely a long term user, but it doesn’t happen in the Mac version of Scrivener. Scrivener uses the Apple text-engine and spell-checking is provided by the system; Microsoft have created their own Mac text-engine, so they’re providing the errant feature themselves. Incidentally, I normally have spell-checking turned off, but haven’t yet investigated how to do it in Word.

I’m sure LAP and Tiho_D, the Windows Scriv developers, will do their best to avoid it happening in the Windows version—I imagine it is still early days in the beta system with much not yet implemented or debugged—but it will presumably be down to the way spell-checking is implemented in Qt5.

Mark

In MS Word 2010, there is a checkbox to turn on or off “check spelling as you type”. I have always kept it turned on, but don’t use grammar checking at all, since I write a lot of technical stuff. I also turn off most of the auto-format options, since I don’t normally use bullet lists and all of that.

There is the same option (“check spelling as you type”) in Scrivener. You can find it under Options > Corrections > Check spelling as you type

Thanks. This has been filed.