[LH2991] Confusing UI when "Add Link" for https URLs

Choose Add Link menu item.
Select web radio button, link is automatically prefixed with http: If you paste in a link with https:// prefix the link is saved with https:// prefix instead.

Workaround, Choose the no prefix radio button and then paste the https:// URL.

As more sites switch to https this is going to be confusing.

Thanks, this is filed–pasting or typing a site with an https:// prefix should just resolve to using that prefix in the link, rather than combining the two. For now, as you note, you can just use the “None” prefix option so that only https:// is used in the link.