[LH3050] Backup on open doesn't work

2.9.0.6

Backups triggered manually work fine. The option to create a backup on project open (File -> Options -> Backup -> Back up on project open) either doesn’t work, or is being ignored. This has been a bug since at least 2.9.0.4, perhaps earlier.

Thanks. This has been filed.

Still not working in Beta 7 from 8/1/18.

I have bumped the internal priority of this ticket, WEEZ. I believe it will be fixed with the next update. Sorry it did not make it in Beta 7.

I’m just curious: Why backup on open? What’s the reasoning behind? Isn’t backup on close the same?

Regards,
M

One use case for this is when a project is being modified by two different desktops via syncing. So you’d have Scrivener take a backup at launch, to capture the other machine’s possible changes.

Scrivener can be set to backup at launch on the desktop when synced mobile changes are detected, but it doesn’t automatically detect changes from another desktop.

Functionally, backup at start and backup at end would be the same since the content being backed up is the same. So I imagine it’s mostly a personal preference. I always make a backup on open because if I get far into the weeds during a session I can just abandon everything I’ve done in that session and revert to the backup. Backup on close would require me to have determined that the product of the session was something I wanted to keep, and if not, I’d have to remember to discard the changes before exiting to avoid them being placed into a backup. Of course, since there would be a series of backups, the prior ones are always available so nothing is truly sacrificed. Backup on open is just my own personal workflow and the way I’ve been working for a very long time; I’m sure both options exist so the users can choose what works best case by case.

Thank you both, my curiosity is satisfied. :mrgreen: You know, sometimes, you have those questions in your head, and if you can’t find an answer, that you know it’s out there, it helps you procrastinate :wink: 'Cause you really, really have to know the answer. :wink:

I can now peacefully go back to my writing. :mrgreen: