[LH3051|2265] Bullet system not working.

I haven’t’ had much need for the bullet system before when writing in Scrivener, and since installing the beta I haven’t tried to use it, so I don’t know if this has been an ongoing issue in the beta or if something happened in the update to 15. I checked against my regular version of Scrivener to make sure that it was working there (it was) and I wasn’t incredibly unclear about how to use something as simple as a bullet system.
When I am typing in the editor, whether I start out with text or plan on typing after I have indicated which bullet type I would like to use, nothing happens.
For example, I want to use the 1.1 1.2 2.1 2.2 bullet layout for some notes that need to be easy to navigate. I started off typing 1. to start off, then decided I wanted to use bullets. I went to the drop down menu and selected the type of bulleting I would like. Nothing happened. My 1. stayed as was, not even a 1. in front of what I had already typed. I highlighted my text and tried again. Nothing. I tried pressing enter, but no 2. appeared on the next line. I tried to tab to get 1.1, but again nothing appeared and I only indented. I highlighted everything and tried selecting a bulleting type, but all it did was slightly change the indenting. I tried changing to a dot bullet and then the square bullet and still nothing happens.
I tried restarting my computer just to make sure that wasn’t something that could fix, but it persists.
Am I the only one having this problem?
I appreciate all the work that is being put into this beta. I am loving most of it so far.

No, it is an ongoing issue in the Beta. It is almost entirely dysfunctional. I use bullets all the time in technical writing and training. This is by far the biggest (perhaps only?) issue I have with the Beta. Each new beta I anxiously check to see if it is fixed.

.

Yes there are currently several known bugs affecting lists. I have updated this thread title with two that are relevant to your points.

Thanks.