[LH3209] "Underline Links" Option Has to Be Re-Enabled Each Session

Under Options, Appearance, Main Editor, there is a checkbox to “Underline Links.” I prefer to have this unchecked. However, if I uncheck it and then close Scrivener, when I re-open Scrivener, even though the box is still unchecked, all the links in my Scrivener project show up underlined. I have to go back into the settings, check the box and apply the change, and then uncheck the box and apply the change for the links to properly display without underlines.

I’m assuming this is a bug. Thank you!

Hi McCarthy777,

I’m not getting the same issue in testing. Are you hitting ‘Apply’ after unchecking the box? Are you adjusting any other options at the same time?

Thanks for your help with this.

I just reset all my Scrivener options to Default and the issue still persists. I’ll outline the steps to recreate it from Scrivener’s default settings:

  1. I launch the Scrivener application and navigate to a document with footnotes or comments. The text of the footnotes and comments in the Editor appear as blue, underlined link text.

  2. I go to Options, Appearance, Main Editor, and uncheck Underline Links and click Apply. The text of footnotes/comments properly changes in the Editor to not be blue or underlined anymore.

  3. I close the Scrivener application and then launch it again, opening the same project.

  4. All the text of footnotes and comments in the Editor now (wrongly) appear as blue, underlined links again.

  5. I have to go into Options, Appearance, Main Editor, check Underline Links (because it is still unchecked even though the Editor doesn’t reflect this), click Apply, uncheck Underline Links, click apply, and then everything works again. So I have to do this last step every time I open Scrivener.

Does that answer your question?

Thank you! Yes, I figured out what I was doing wrong. This has been filed.