[LH3223] Spell check doesn't work if "Check spelling as you type" is unchecked

Scrivener 2.9.0.6 on Windows

I turned off check spelling as you type because it’s really distracting, but I still want to be able to spell check when I’m ready.

To be honest, my strong preference would be to be able to set a hotkey to toggle this option on/off (I saw in another thread for an older version that you used to be able to do that with Ctrl /) - is that possible?

Although, either way, I don’t think Spell Check is working correctly:
If I have Check Spelling as You Type unchecked then when I do Edit->Spelling, it immediately comes back “Spell check complete” with no errors.

If I then turn Check Spelling as You Type back on, a) I can see red underlines that some words are wrong, and b) when I do Edit->Spelling it takes me to the spelling errors.

Thanks!

Just to confirm this behavior. I usually use “check spelling as you type,” but it can be annoying. So I turned it off to check this bug report, and, since I have some words deliberately misspelled, expected on running spellcheck to get zillions of errors. Nope. “Spell check complete” with no errors. And I know that’s wrong.

Thank you. This has been filed and should be fixed for the next beta release.