[LH3373] Context menu for format changes doesn't work correctly.

Create a document and put text in it.

Change “No Style” to have a different font.

Select the text in the document. Right click -> Style -> (choose a different style).
The text changes format (I tried both Attribution and Block Quote).

Keeping the text selected, Right click -> Style -> No Style. The text DOES NOT CHANGE STYLE back to No Style. This is the bug.

Click on the formatting drop down, click on No Style, and the text changes back to No Style. The context right-click menu should be using the same function, should it not?

No Style is not a sneaky default style. It is literally “no style is applied.” Therefore, it will not make any changes to any text attributes you have applied.

In that case, clicking it in ANY menu should have literally no effect? Then there’s a bug. In one menu it changes formatting, in the other it doesn’t.

I think it would be handy if the styles window displayed a default ( “body” or “normal” ) style, as well as a “no style” or “undefined” style – ie: the difference between the style chosen by default where no other style is selected, versus any deviation / modification from any starting point that has not been saved as a style.

Such a “default” style was in place for a little while during early Mac 3 days and then removed because it complicated use of the styles system, in KB’s point of view. As such the behavior was removed from the Mac version, which means it is unlikely to be added into the Windows version.

https://forum.literatureandlatte.com/t/styles-in-scrivener/41591/6 might provide some interesting reading.

Getting back to the original issue, I agree with Rwfranz that this most definitely sounds like a bug – a given command should do the same thing regardless of whether you pick it from a right-click or somewhere else.

And it is NOT true that clicking “No Style” should have no affect – that makes no sense. There would be no way to remove a style from a chunk of text if that were the case!! My understanding is that the point of the “No Style” option is to strip away any styles applied to the text, as described in great detail in the Mac manual in section 15.6 (p. 412 in the PDF I just downloaded):

(I use both the Mac version and the Windows Beta, and I’m expecting they will get closer to working the same as the beta progresses, so I find the Mac manual helpful for the Windows beta)

So, testing the original issue –

  1. I applied a style to a chunk of text. It changed formatting as expected.
  2. Then from the format bar, I picked No Style. The style I had applied is correctly stripped away and the text goes back to the “default”

Then, repeat this using the right-click menu:

  1. Apply a style to a chunk of text (I used Attribution).
  2. Right-click > Style > No Style. NOTHING happens, the chunk of text still has the “Attribution” style applied.

Hopefully the windows devs will fix this one up, as the right-click is way more convenient than the format bar or Format > Style menu (although I just tried the Alt+0 shortcut and that DID work)

That depends on whether you think the style is the piece of metadata within the text that says “this chunk of text should be rendered in the style Foo” or the formatting that Foo currently happens to be defined as. In many programs, the two are essentially the same. In Scrivener, I get the feeling it’s a lot more loosely coupled. It would be interesting to play around with this in the Mac OS version and see if the same thing is happening there – if so, there’s probably a reason for it.

Okay, playing around with this in Mac Scrivener 3.1 beta, setting the format via right-click, via Format menu, and via the Styles panel all do the same thing, so the bug that you’re seeing in the Windows beta (where they aren’t the same) is definitely there.

However, it is interesting to note that at least in one test case, I took the “default format” (no style) and applied it to the text, then change to Block Quote, then clicked on No Style/Remove Style. In this case, the formatting was removed but the line indent did not go back to the original. I had to use Undo to get it back to original condition. I’ll be posting that in the Mac Beta forum.

This has been filed. Selecting “No Style” from the right-click menu should definitely do something :wink: