[LH3425] BUG - D:\icon.png

When creating backups, I receive an error that states something about "…could not save “D:\icon.png” – which appears to be the last custom icon selected for a folder or document. For no apparent reason, Scrivener is placing this icon in the root of the D drive. The backup progress gets stuck at 50% and never completes. This occurs with autosave backups, as well.

Not sure if this is relevant, but the pop-up dialog that reports the error message is entitled, “Scrivener…Delayed Write Failed”
It’s worth noting that my project is located on C:<folder> and the backup folder is located in D:<folder1><folder2>

Scrivener (476684 x64)


Additional info:

I was able to resolve the issue by selecting C:<folder> as my backup location. This is the same volume where the project resides, which is not ideal – since the backups are now stored on the same drive as the project, creating a single point of failure.

I don’t know if this is relevant, but the D:<folder> used for backups (where the issue occurs) is a flash drive. Very high speed, but flash, nevertheless.

Another side note, Bitlocker encryption is enabled for both drives.


Hi All,

Please see Tiho’s response here : https://forum.literatureandlatte.com/t/lh-3425-beta-13-changing-folder-icon-in-binder-puts-a-png-file-of-that-icon-on-my-d-drive/44521/1


Some more info, since the error I received is a separate issue from the icon.png referenced here:[url]https://forum.literatureandlatte.com/t/lh-3425-beta-13-changing-folder-icon-in-binder-puts-a-png-file-of-that-icon-on-my-d-drive/44521/1]

After changing my backup folder to be only a single level deep (i.e. D:<folder>) from being two levels deep (i.e. D:<folder1><folder2>) the error when autosaving backups seems to be resolved.


I’m glad it’s working for you!

If you can remember to do so, please test this out again when the new beta comes out, with your backup folder set to where it was originally. I’m curious to see if the interaction with the above bug may have been causing some of your problems.

Thanks for your help with this!