[LH3459][LH4272] - Spellcheck false positive if word ends with an apostrophe

Been around for a couple Betas, but took a bit to realize it was a bug.

If a word ends in an apostrophe spellcheck thinks it’s a misspelled word, Correcting the word add an extra ‘s’ on it, removal of the extraneous s then once again flags the word in the spellchecker.

i.e. ‘bliss’ is corrected to ‘blisss’

Windows 10 1903
Scrivener Beta 29

This has already been noted and has a tracking number as seen here; https://forum.literatureandlatte.com/t/lh3459-b18-words-ending-in-s-marked-as-mis-spelt-if-followed-by-closing-single-quote-mark/46046/3

I’d like to note a very similar bug / issue, which likewise needs to be resolved: When a footnote abuts a word anywhere in the midst of text (e.g., at the end of a word within a sentence), that word is then flagged as misspelled. Scrivener should recognize that the given word and the first word in the immediately following footnote are not a single misspelled word. (I have not checked recently, but this could be an issue with inline comments as well.) I have thousands of footnotes (literally) in each of several books I have written and am writing, and having to constantly deal with false spell-check results for the above reasons is painful and actually time-wasting. (Please fix this.)

Can you show (get a screenshot) of this? I’m not sure how to replicate what you are reporting as I don’t normally do inline footnotes. As a matter of fact, I’m not even sure how to do inline footnotes. My test with inline footnotes (either via menu or shortcut key (Ctrl+Shift+F)) turns it on, but how do you get out of it?

Use the Inline Footnote command in Scrivener, and place the text of the note, which will be highlighted, against the end of a word, for example, and then do a spell-check. This is quite easy to reproduce, and inline footnotes, like inline comments which have the very same spell-check issue, are standard features of Scrivener. If you do not know how to do one or the other, then read the related information in the tutorial, for example.

Still a problem in Beta 35, btw.

Addressing the OP. The issue is with the single quote (smart quote) mark and is part of the spell check module. I turned on Show Invisibles to make things easier to see: A note: numbers immediately following the single quote do not trigger the spelling error either while a letter will flag everything.

The hijacked part of the thread here concerning inline footnotes and annotations. Until you compile the document (where Scrivener works with the code itself to display or convert the inline footnote or annotation), it is just text for the spell check module to work with. You need to add a space between the inline annotation or footnote to let the spell check know these are not just run-on words. This is the same behavior as in Scrivener 1.9.


Inline footnotes - Scriv 1.9.png

Even if the spell checker works in groups, I would still recommend to add spaces(word separators) between the inline notes and the main text. Have in mind that Find and Replace searches will not recognize the inline notes borders. In your first example it is treated as one word “annotationsrequire”, and in your second example “chaptersThis”, will be treated as one word which might cause you troubles searching and replacing text. This is also the way Mac handles these.

We recommend using leading/trailing spaces which can be easily removed during compile.

The apostrophe spellchecker will be improved in the next update.

Thanks, Tiho! Adding the space between the inline footnote and/or inline annotation was what I usually did. As for the apostrophe issue, here are my results with the sample file I created above. The few errors left I can live with (they were worst-case extremes anyway or follow the adding a space between words rule). Looks good!