[LH3484] Problems with collections

I have a collection where I collect all scenes I want to sync with an external folder. However, that collection isn’t working very well. I open the outliner, and want to drag and drop scenes from there into the collection. Nothing happens. First I tried to choose several scenes at once, then one at a time. When I drag them to the collection, it shows a plus sign, but the texts don’t end up in the collection. There is no option when I right click a scene to “add to collection”.

If I open another, older, collection, I can add scenes from the outliner in the way described above. I can also add scenes to my syncing collection by right clicking in the Binder, and “add to collection”. However, if I chose all the scenes I want in the Binder, they just end up in a totally random order in the collection, as far as I can see. And it is also frustrating not being able to se the scenes I want to add and the collection at once, as the Binder and collections can’t be shown at the same time.

Am I missing something?

There are two kinds of collections, those you manage yourself (which it sounds like you are accustomed to), and those that have their lists built automatically by a saved Project Search query. You can’t modify the latter, save for indirectly causing things to match the filter.

There are a few visual cues to help you recognise which type of Collection you’re looking at. Saved Search Collections will have the following characteristics:

  • A magnifying glass icon to the left of the collection’s name, in the tab list. Not implemented yet.
  • The background colour will alternate between darker and lighter for each row, as opposed to being a solid colour.
  • Right below the collection header bar will be a sort tool, set by default to “Binder Order”.

If that’s what you have, and that wasn’t your intention, then with the Collection shown in the sidebar, use the Navigate ▸ Collections ▸ Convert to Standard Collection menu command.

That part is no longer true in the new design (which it is important to note, isn’t working yet in the beta). Beside the X button where you would close the collection, you’ll see a “hook arrow” button. Click that to load the Collection list into the main editor, and then X to return to the Binder. Now you can drag things in either direction, to move the item to a different place in the binder, or to assign an item to the collection, depending on which way you drag. The Lock in Place feature will probably be of use to you (Ctrl+Shift+L), so you can more freely work with the binder.

Again like I say, that’s not entirely working. They don’t allow drag and drop into the editor from the binder, as a way of managing the collection list, or even drag and drop within the list to reorganise. So maybe come back to this workflow once you’ve seen some release notes on it.

Thank you!

It is an “ordinary” collection, not a search collection. I tried again, and then it actually worked to drag and drop from outline in the editor to a collection I had created. But after that, I emptied the collection to start over, and then again it didn’t work. It seems like it is possible to add scenes to a collection where there already are scenes, but not to an empty one. A bug, or am I doing something wrong? As I said before, there is a plus sign beside the cursor arrow, so it seems as it should work. When I right click any document in the outline there isn’t the option to “Add to collection”, which is there when I right click in the binder.

Sounds like an excellent idea when it is functioning!

Ah, I see what you mean now. That was the missing ingredient: that the collection has to be completely emptied. Dragging will then look as though it will work, with a blue placement line drawn at the top of the collection view, and like you say the “+” badge on the pointer, but then nothing happens on drop.

What does work:

  • The Documents ▸ Add to Collection ▸ submenu, which is of course the universally available command you’ve been accessing from the contextual menu in the binder.
  • Dragging to the tab instead of the sidebar list. You’ll need View ▸ Collections toggled for that, of course (Ctrl+Shift+9).

Either way, once you have one in the list it seems to work normally from that point onward. So for now that’s how I’d work around it—and also make use of the how the feature adds selected binder items when creating new collections. You only get empty collections to start with if nothing is selected. That selection can be pulled from either the binder or the outliner. Thus only a small tweak in the order of how you do things should be necessary to this condition.

Meanwhile, I’ll file the obvious bug. :slight_smile: Thanks!

Thank you! No problem, I find a way to work around it, it just confused me…

I must note that a prior report of this bug did not elicit a response.

2.9.0.11 Can’t drag Bookmarks into a new Collection

Rgds - Jerome

Thanks for the catch! I’ve double-checked your description and it looks like we have everything noted.