[LH3563] Document links and bookmarks do NOT create a back-link bookmark

Although the option (Document links and bookmarks create back-link bookmarks) is checked in Options > Behaviors > Document Links, creating a bookmark or document link do NOT create a back-link bookmark.

beta 21

Regards,
M

It looks like some things are working but not others:

  • Dragging one item into another’s bookmark list: good.
  • Creating a new linked document via Ctrl+G,D: good.
  • Using the button to manually create a bookmark to another item: good.
  • Dragging a document into the text area to link to it: fail.
  • Right-clicking on selected text, or using the Edit menu, to “Link to Document”: fail.
  • Dragging an image from the binder: good
  • Using the Insert ▸ Image Linked to Document submenu: good

Anything else I’m missing? I don’t actually get a case where creating a bookmark doesn’t work, so I’m not thinking of something.

Right-click at an empty place in a document then choose Link to Document > select any existing document. It creates the link to that document, but not a back-link.

Then there is this visual glitch (see the attachment):
Clipboard Image.png

As you can see half of the link is blue and underlined and the other half is not.

Also, if I drag one item into another’s bookmark list, from one project to another, it doesn’t create a bookmark at all. Should it?

Okay, yes, that’s the fifth case I marked above, one of the ones that isn’t working.

The link is fully marked, the problem is that spell chark marking takes precedence over other dynamic drawing, the way I see it.

That’s something else entirely. External linking like that will not create back-links. That said, you’re right, it should be working—it once did. Now the ticket is open again.

In beta 22 using the … button to manually create a bookmark to another item does NOT create a back-link anymore.

It was working in beta21

In v25

  • Dragging one item into another’s bookmark list: good
  • Creating a new linked document via Ctrl+G,D: good
  • Using the button to manually create a bookmark to another item: Doesn’t work anymore. Use to work in v22
  • Dragging a document into the text area to link to it: fail
  • Right-clicking on selected text, or using the Edit menu, to “Link to Document”: fail
  • Dragging an image from the binder: good
  • Using the Insert ▸ Image Linked to Document submenu: good
  • Drag one item into another’s bookmark list, from one project to another: fail

Thanks for checking all of those variations out; I’ve updated the ticket.