[LH3628] Incorrect keyboard binding for text indent functions

Text indent key bindings do not appear correctly in menus or function properly.

I have assigned Increase Indents to CTRL+M and Decrease Indents to CTRL+SHIFT+M.

However, when viewing the functions via Top Menu > Format > Paragraph > Increase/Decrease Indents we can see that these are not shown accordingly.

Instead, Decrease Indents is shown as having no key binding and Increase Indents is shown as CTRL+SHIFT+M, which is also how they act when I attempt to use them.

For clarity, I have assigned under options > keyboard bindings the following:
Increase Text Indent to CTRL+T,
Decrease Text Indent to CTRL+SHIFT+T
Increase Left Indent / Increase Indents to CTRL+M
Decrease Left Indent / Decrease Indents to CTRL+SHIFT+M

These are somewhat confusingly named, which may be the norm as I’m not aware of how paragraphs are typically done, but just in case: text indent here refers to the paragraph ignoring the first line, where as left indent/indents (which is plural) refers to the first line only.

I realized that CTRL+M was listed also for Merging Documents and removed that binding, but it had no effect on the functionality of CTRL+M here or to make it appear in the menu.

Sorry, I’m a nitwit and didn’t label the post correctly with “BUG:”

Scrivener Version: Beta (594259) 64-bit - 18 Jun 2019
Windows version

On further testing, it appears that Increase Text Indent uses whatever key binding you have listed for Decrease Text Indent, and Decrease Text Indent remembers no shortcut at all.

It turns out that within the Options > Keyboard settings you can see that both [Increase Text Indent] and [Decrease Text Indent] refer to the same label - [Increase First Line Indent]. Nothing has been assigned with the label [Decrease First Line Indent].

Edit: Golly, this is confusing to look at.

So I’ve gone and adjusted my settings again and there’s other wonky business at play.
Increase Text Indent [Increase First Line Indent] to CTRL+T,
Increase Left Indent to CTRL+M [Increase Indents],
Decrease Text Indent [Increase First Line Indent] to nothing,
Decrease Left Indent [Label: Decrease Indents] to CTRL+SHIFT+M.

However, now Format > Paragraph > Increase/Decrease Indents says otherwise:
Increase Indents is CTRL+SHIFT+M instead of CTRL+M,
Decrease Indents is blank instead of CTRL+SHIFT+M.
Increase First Line Indent is CTRL+T, over riding the other blank.
Decrease First Line Indent is blank, correctly.

If I’m being too confusing let me know and I’ll add screenshots!

This has been filed. Thanks.

I just wanted to confirm that this hasn’t been resolved in current release candidate. This is confusing to explain every time because we have a description, a label, and the menu label. Oof! I’ve included a screenshot.

There is no functioning key binding to decrease paragraph indents.
Decrease Indents keybinding does not show up in Scrivener Indents menu.
Decrease Left Indent keybinding instead acts to ‘Increase Indents’.

Labels are incorrect and inconsistent vs descriptions:
Decrease Text Indent does Decrease First Line Indent, but has incorrect label of Increase First Line Intent.

Functioning properly:
Increase Text Indent with Label Increase First Line Indent does Increase First Line Indent.

Just confirming that this remains an issue with RC3. I’m happy to make a video of the bug if helps clarify things.


Scrivener Version: Beta (1017011) 64-bit - 14 Aug 2020
Windows version 10.0.18363

The shortcut key for “Increase Indents” does not work (and has never worked) for me. The default hotkey “Ctrl+Alt+I” does not indent. When I try, all it does is type a capital I onto the cursor position.

I have also tried changing the shortcut to various things, to no avail.

Thanks for any help you can give to this :slight_smile:

~ Sean

The indent hotkeys work for me again. Thank you!