[LH3648] Project Stats and Composition mode bugs?

Just updated to v18. As an aside, I couldn’t get the update to work from within Scrivener itself. I downloaded the installer separately, but for some reason, it wouldn’t work, even when I tried to run it as an admin. I ultimately had to run it in Windows 8 compatibility mode for it to install (I’m on a Windows 10 64-bit machine).

So far I’ve noticed these things, and I’m wondering if anyone else is having issues with them:

  • Project Statistics is no longer updating. I’ve written a couple hundred words this morning, but the counter for session target is squarely at zero.
  • Project Statistics doesn’t reset at a set time. I have to manually reset it at the beginning of a session.
  • When I exit composition mode, Scriv 3 remains in a maximized window, but the contents of that window are small. So the interface and editor of Scrivener only takes up maybe a third of the window. I’ve attached a full-screen screenshot to make this a little more clear. The only way to fix this is to “restore down” the window and then maximize it again.

The issue regarding Composition mode has been filed.

As for your Project Targets issues, could you upload a screenshot of your Project Targets Options? It’s possible something is set there that may be causing these issues and an image would help us find out quickly.

Thank you for your help with this.

Sure. Here are screenshots of both the project target (which I don’t have set to anything in particular) and the session target. The only parameter I changed from default was switching the reset time from 12:00 AM to 5:00 AM. Everything else I left the same. I also noticed that I can’t click to set writing days, but I wasn’t sure if that was a bug or just a feature that hadn’t been implemented yet.

session target.PNG
project target.PNG

Try unclicking “Count current compile group only” and “Only count documents set to be included in Compile” in Draft targets and clicking “Count text written anywhere in the project” and see if that affects anything.

As for the reset, we have a bug where the session target will be reset at the correct time, but the quicksearch bar still shows the old session number until a new word is typed. You said that you have to reset it manually at the beginning of the session - when you do so, does the Project Targets window also have the old session amount? or has it correctly been reset?

Thank you!

So weirdly, before I changed those settings, the word count was working again. Although sometimes it stops working when I switch to typing in a new text (regardless of whether or not I had clicked “Count text written anywhere in the project”). But I haven’t been able to reproduce that reliably yet. I’ll try to keep an eye on that and on what the parameters are when I see it again.

The last time I went to reset the Project Targets window, it had the old session amount there until I manually reset it. I can’t say exactly what it was before this last time though because I didn’t pay close attention to the number, only noted that the bar was still green and hadn’t reset. I didn’t notice the session count in the quicksearch bar, but I’ll try to pay attention to that next time.

Thanks for your help!

Okay, so I paid more attention when I booted up this morning. Both the quicksearch session number and the project targets window had the yesterday’s session count. When I manually reset the session target, both went to 0. I forgot to try typing something to see if it would reset upon new words being added though–I’ll have to remind myself to do that tomorrow.

Checked it this morning, and the session target does not reset when I start adding words. Just increases yesterday’s count unless I manually reset.

I’m in the same boat. I’ve tried everything previously suggested in this thread and I can’t get the Project Target to show how many words are in the MS nor will it show how many I’ve written today (or any day over the last few weeks). I even created a whole new project, copied and pasted the four chapters that I have and it still isn’t working. :frowning:


Just downloaded v19 and it’s still an issue. I’m guessing it’ll be fixed by v20. Thanks.