[LH4056] Bug 2.9.0.22 beta, substitution issue with non-breaking space

Hi,
In main editor, I have no trouble to insert a non-breaking space (doing Ctrl+shift+space bar), but when I try to insert it in
file -> options -> substitutions -> edit substitutions
it does a regular space instead. I can’t copy it there, neither replace it when compiling. And I did enable additional substitutions. I am trying to insert it before a “:” (for French) and after an em dash.
Thanks

I am using Windows 10, beta 2.9.0.22 (64-bit).

In the beta 2.9.0.24, I still can’t insert a non-breaking space in the substitution. In the “edit substitution” window, I tried copying the non-breaking space, it does not work. I tried inserting the unicode 00A0, it does not work. I tried to do Ctrl+Shift+space bar, but it still does not work. It is very unconvenient for French ponctuation.

Thanks, this has been filed.