[LH4060|LH3201] Bug beta, selected files does not always shows in the compile window


I am not sure if someone already listed that problem or not.
When I click on a file (text icon), then I hold shift to choose other files to compile (doing only one click), it works and all the selected files shows in the compile window. But eveytime I click more than one time while holding shift, the files does not shows in the compile window.

I am using Windows 10, beta 64bit

In the beta, it’s working very well with Shift, thanks! But I just find out that the same problem is happening with Ctrl.

Could you post specific steps for reproducing the problem? I’m not sure if I’m testing this correctly from your description. Are you talking about creating a multiple selection of text documents/folders in the binder, then opening compile and selecting “Current Selection” as the compile group? Doing this is giving me the expected items in the list, but I may be missing the critical step that’s causing a bug–assuming this is what you’re seeing. :slight_smile: If it is, bear in mind that only text documents/folders can be compiled, so any image, PDF, or other media files included in your selection will not appear in the list.

OK, I don’t know what happened but I tested it again, and it does not work with Shift nor Ctrl. So, it’s still a bug with both keys.

My steps:
I have created multiple text folders.
To select some of them in the binder, I hold the Shift key (for multiple selection) or Ctrl key (for a selection one by one), then click on the text folders that I want to select.
Here is the bug (please refer to the print screen). For example, if I select one by one folder by holding Ctrl, then clicking on “Prologue”, then on “2:Fille du vent”, then on “3: Trouve refuge” (so I clicked 3 times), when I click on compile, those folders does not appear in the “Current selection /Sélection actuelle” in the compile window (like you can see in the other print screen).

It does the same by holding the Shift key to select folders in the binder. Everytime, if I click 3 or more times in the binder to choose the folders I want to select, it never appears in the Current selection of the compile window. But if I just click 1 or 2 times to complete the selection, for example holding Ctrl, I click on “Prologue” then on “1: L’incomprise”, when I click on compile, those folders appears in the Current selection, as you can see below.

I hope it helps. Thanks!

Thanks, that does help. I’ve done some more testing with this and found a problem with how Scrivener is pulling the selection which might explain the behaviour you’re seeing. It should work that the selection is taken from the binder, outliner, or corkboard depending on which has the focus, and from the binder if anywhere else in the interface has focus. At present, this isn’t working right, so moving focus outside these areas can cause the compiler to see no selection, or an unexpectedly limited selection.

Could you try the multiple selection again and ensure that focus remains in the binder before immediately selecting compile? (Using the shortcut Ctrl+Shift+E may help avoid a stray click into the editor, etc.) If you do this, do the items appear in the content list as expected?

As you asked, I tried again the multiple selection, making sure that I only click in the binder. I also used the shortcut Ctrl+Shift+E to open the compile window, but no item appears in the content list. It does the same (not working) using shift or using ctrl to select the folders. Sorry…

I don’t know if that can help you to find the problem, but right after I updated from beta 23 to 24, I tried those multiple selection and it was working with the shift key (not with the ctrl key, though). Then, later, after I closed scrivener and started it again, it was not working again, So, I am wondering if it was really working right after the update or I just dreamed it :wink: .

Thanks for trying. Are you able to reproduce this in a new project? Try creating a new blank project, adding a four files with some text, then doing the same method to select the files and compile the current selection. Do you see the same problem?

One other thing to check, in your main project, click the filter icon in compile, to the right of the dropdown menu. Is that set to “included documents”, with the filter deselect? Since this is working with just two of the three documents, I don’t think this can be the issue, but best to double-check!

OK, I checked and in compile, it’s set to “included documents” with the filter deselect, like you said, so that is not the issue.

I also created a new blank project from an empty template (I use scrivener in French, so I am not sure about the right name for it, in French it’s the template called “vide”) with 4 text folders and tried to do a multiple selection. What I saw (please refer to the print screen below) is that it’s working only if the main folder (in the example, “brouillon” or “dossier sans titre” are in corkboard mode or outliner mode but not when in scrivenings mode (as you can see on the image with scrivenings mode).

In my project, it does not work in any mode, but maybe it’s because I used a customized template for my fiction novel. I should mention that I started this novel when using scrivener 1,9. I tried to create another project with my customized template and I can’t. A message tells me to update the template, which I do, but it does not change anything, I can’t create a project with that template. If I remember well, I think I was not able to import this template from 1.9 version to the beta, so I created a new template in the beta, but from this old project that I started in the1.9 version. So, maybe that is a part of the problem.

OK, I think this is the result of two bugs–one, what I described before, that depending on the focus, the incorrect selection (or no selection) is being used for the compile group, and two, that the binder is losing focus on the third selection when the editor is in Scrivenings mode. This is why you’re able to get two but not three items appearing properly, and why even trying to keep focus in the binder and jump via the shortcut to the compile window, it’s still ending up blank.

Both these bugs are logged; for now, you should be able to work around it either by switching to the outliner or corkboard after creating the binder selection, and using Select-All within the editor to focus and select the items, then open compile, or by using Ctrl+Tab to force focus back to the binder after making the selection while in Scrivenings mode, You should see the difference in highlight color there to indicate whether or not it has focus.

I don’t think anything in an older project should be affecting this, so try it out in that project. If you’re still having trouble, we’ll take a look at that project specifically and see what else might be going on.

Thanks! You’re right! If I follow those steps, it’s working perfectly in my project, using the shift key or the ctrl key to select the folders. :smiley: