[LH4214] Changing paragraph style also change font of character styled text in paragraph. Not a new bug.

Italics is obtained in 1st image with “character style” “emphasis”.

Apply paragraph style “block quote” change font.

It works perfectly all right with my ‘emphasize’ style.

I would recommend to play with other fonts first—it’s highly probable that seemingly changed one shows a font substitution (i.e. a missing one).

Very strange bug, indeed. Looking into it for more details on how I get it.

jljovano, yet another point to consider—name of italic set in the ‘emphasize’ style: a problem might arise if you set, say, ‘Times Italic’ while the name of respective typeface installed in your system is ‘Times Oblique’ or something.

Ok, made some other tries on 2 computers, and … well, styles are just broken.
Just with the tutorial project, I could get a nice variety of results :wink:
Also tried to change language to english, same result…
Font names or missing fonts or anything, it does NOT work as it should…

edit : problem found to be on paragraph styles without font defined, with font it does not happens.

This has been filed. Thanks!

It looks as though this only occurs when applying the paragraph style last. If instead the paragraph style is applied first, followed by applying emphasis, the font should remain correct.