[LH4415] Typewriter scrolling is forced on when switching to composition mode

Title says it all.

  1. Enter composition mode F11
  2. Turn off typewriter scrolling with ^G^T or using the popup “task bar”
  3. Leave composition mode
  4. Return to composition mode
  5. typewriter scrolling is back on again

The same is not true in reverse, i.e. the main editor retains its typewriter scrolling status.

The manual says “This setting is specific to each split editor, as well as to composition
mode (the latter has the feature enabled by default).”

Version: 2.9.0.42 Beta (861203) 64-bit - 11 Mar 2020

FWIW, version 1.9.x has typewriter scrolling turned on by default in Composition mode. As the manual says and as you quoted above, “…composition mode (the latter has the feature enabled by default).”

Yeah, “enabled by default” is somewhat ambiguous. My expectation is that it retains state aka is sticky, just as it is when returning to the main editor. When I don’t want it, it’s 3 keystrokes to enter composition mode.

Thanks guys, this will be fixed in the next build.

Cool!
I gotta say I love, love, love this software, and as a long-time developer, I am in awe at the complexity involved. I can look at most programs and think “Oh, I can see how they do that,” and for Scrivener, you are juggling a huge number of states.
(An exception is Google Maps; how do they track road speed, my speed, lane needed for exit, traffic conditions, etc. and present it all in near-real-time??!)